Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Wheels & Tires - Sponsored By Tire Rack > Subframe issues

Wheels & Tires - Sponsored By Tire Rack The place to go for answers on wheel types, tire sizes, offset, wheel patterns and more.
Sponsored By:
Tire Rack


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Subframe issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-07-2013 09:58 AM
bringler26 The subframes should be the same. the changes were made to the knuckles where the struts bolt in. otherwise there should be no difference.
03-07-2013 12:35 AM
dcorwin822 Shitty cellphone pic of the subframe. When I can get a chance i'll see if I can put the car on a lift at work to get better pics.

subframe front to back pic
02-28-2013 10:11 AM
rambleon84 i know the rear subframes will work from older focus in your 08 but i havent heard if they are the same in the front. Post a picture of what you mean, im sure the 08+ guys will chime in.
02-28-2013 09:07 AM
bringler26 add some pictures maybe that will help.
02-28-2013 07:51 AM
dcorwin822 No one knows? bummer for me.
02-26-2013 11:53 AM
dcorwin822
Subframe issues

Hey, I think i bent my subframe. Is it supposed to be bent upwards a bit near the front where the engine torque mount is? I think this may be causing my swaybar to walk. Will a older subframe work on my '08 focus?

I know the bolt that holds the torque mount in is different but that's one nut and bolt difference that I know of. I kinda need to know soon so I can get this taken care of asap.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat