Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > i don't know where to start??

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: i don't know where to start?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-22-2013 08:53 PM
pvttaylor07122 Now im throwing all these codes p0177 p0102 p0113 p0135 p1518 p1520 p1121 and ill p1132 everything i do just seems to mess it up more
02-22-2013 02:06 PM
pvttaylor07122 Well i unplugged it and it held it open took the mass air flow off and cleaned it the imrc started working right i think the put a cheap mass air flow sensor on it so i need to find the right one and a stock air box
Posted via FF Mobile
02-22-2013 03:31 AM
sleepyboy Moved to Technical Chat



Quote:
Originally Posted by pvttaylor07122 View Post
I just bought my 03 svt focus and it has some problems Idk if one thing is causing it all i know my imrc is stuck open when i plug the mass air flow in i get horrible gas mileage o2 sensor is running rich and when its cold it jerks really bad and dies sometimes at stop also had a rough idle and no power at all


I'm not sure what your saying here? Bad gas mileage can be caused by the IMRC being stuck, MAF being dirty, or bad O2 sensor. Try cleaning the MAF with some MAF cleaner, that may fix it running rich and the O2 sensor may just be reading rich due to that. Running rich will cause bad gas mileage. I'm pretty sure that when the IMRC is unplugged it's stuck in short runner mode not long runner mode too.
02-22-2013 12:22 AM
pvttaylor07122 Thanks ill give it a shot
Posted via FF Mobile
02-22-2013 12:16 AM
Elizabeth Disconnect the IMRC cable. Better to have them closed, and have poor response over 4,000rpm, then terrible response below 4,000rpm.
02-21-2013 11:48 PM
pvttaylor07122
i don't know where to start??

I just bought my 03 svt focus and it has some problems Idk if one thing is causing it all i know my imrc is stuck open when i plug the mass air flow in i get horrible gas mileage o2 sensor is running rich and when its cold it jerks really bad and dies sometimes at stop also had a rough idle and no power at all

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:52 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.