Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > car lost all power

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: car lost all power Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-24-2013 12:28 AM
cargo99
fixed

Thanks for the quick reply. problem solved, it was the f8 30 amp fuse, I guess somehow I overlooked that fuse the first time I checked them. Thanks again!!
02-21-2013 10:41 PM
elsolo I would start with fuses, checking both for blown fuses and voltage on the circuits.
You have volts at the battery, now you need to systematically check downstream.

There is also the power hold relay and it's diode.
If the diode gets fried, I think the power hold relay will stay self energized as long as the engine is running.
02-21-2013 10:13 PM
cargo99
car lost all power

hello, needs some help with 2003 ford focus zx3. My son reversed the car in the driveway today and the engine started to sound awful. (His description made it sound like the timing was off) anyway he took the key out and it would not turn off so he stuck the key back in and released the clutch to stall it out and that turned it off. He tried to turn the car back on and nothing happened. The car has no power when you turn the key. No cluster lights or radio, No clicking, No fuel pump sound. When you turn on the headlights the cluster lights work but the headlights don't work, only the parking lights. We tried to jump it and didn't work, tried to push start it and that didn't work. I checked the ignition starter fuse and it checked good. I m not sure where to start, nothing is making sense to me. The Pat light is blinking slowly even as I try to start car, dont know if that is normal. Battery is showing 12.5 volts. Please help me out so I can sleep peacefully again.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:06 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat