Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Horn does not work

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Horn does not work Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-29-2015 07:26 PM
sailor Extended warranties are extremely variable on coverage/deductibles, only the ppwk. you bought will give the answer.

Each provider & version they sell varies, even Ford has different levels avail..
08-29-2015 10:56 AM
Gc2tone32
Quote:
Originally Posted by sailor View Post
Show 'em a car that's under 36 mo./36,000 miles and under the bumper to bumper warranty?

This thread talks about earlier year different models than your '12 MkIII, any info. here might not apply.
Haha that would be great if I fell under the warranty but unfortunately I am over on mileage. However I do have an extended warranty that covers me to 120k miles. Hopefully I can use that and not have to pay any deductibles. I don't know how those extended warranties work
08-29-2015 12:47 AM
sailor Show 'em a car that's under 36 mo./36,000 miles and under the bumper to bumper warranty?

This thread talks about earlier year different models than your '12 MkIII, any info. here might not apply.
08-28-2015 10:12 PM
Gc2tone32 OK so my horn Is not working as well. The fuse is fine and the relay is clicking. In earlier posts I read something about a tsb free horn replacement. My question is what would I have to show or provide to the dealer for them to honor this for free??
05-14-2015 04:56 PM
Leora83 "My horn blows" actually means the horn doesn't blow. Like your vacuum sucking...
English is fun.

You said you tried to switch the relay...so you did switch it or didn't? Make sure it's a known good relay. If it was, then your issue is likely the switch in the steering wheel.

Disconnect the battery and wait AT LEAST 30 minutes before opening up the wheel or you risk getting the airbag in the face. Sure, it's funny on YouTube, but not when it happens to you.
05-14-2015 03:54 PM
ferjaram I mean it works when I run it to the battery, but when everything is hook up it wont blow.
05-14-2015 01:00 PM
sailor Yeah,

Leave it alone, you said it works.

Relays don't need to make an audible click to function, noise level varies tremendously. Why worry if it's functional?
05-14-2015 12:33 PM
ferjaram I have a problem too. My horn works it blows. But the relay doesn't click. I tried to switch out the relay and still no click. Any advice
05-02-2015 05:29 AM
amc49 'Basically the horn bracket is wrong and the horn gets water in it and stops functioning.'

I've seen that before on other cars, do those guys ever even think about that issue???

I've actually done what it takes to re-orient the scroll openings to make them shed water instead of ingest it. Never had one of those then later go bad unless the case itself leaked where riveted together. Drill rivets out and use small screws and nuts and glue it back up with silicone after dressing the points and resetting the diaphragm screw to make noise and blow the sh-t out of it.
04-29-2015 09:50 PM
sailor 3 items not working which use that part pointed to it pretty well.

Glad you confirmed it, when I saw this earlier tonight there wasn't an easier way to prove the issue I could think of than pulling it for checking.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:04 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1