Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus > Horrible Noise from Rear of Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Horrible Noise from Rear of Focus Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-13-2013 07:36 PM
suss6052
Quote:
Originally Posted by BetaDnB View Post
If you notice, a couple key points of information were not typed into the first post.
Exactly, since they neglected to mention that the rear stabilizer bar had been changed for an aftermarket part.

They jumped straight into the Lemon Law issue rather than admitting it might have been something they had done.

The tail lamp/ paint issue is not a lemonable issue as it doesn't effect the car's functionality, etc.

The fact that they neglected to consider the part they changed as being an issue and jumped straight to the shocks and or springs as being an issue rather than the stabilizer bar itself.
02-13-2013 07:34 PM
sgmfocus
Quote:
Originally Posted by BetaDnB View Post
If you notice, a couple key points of information were not typed into the first post.
sorry for replying didn't know it would cause problems by reading what was posted
02-13-2013 07:29 PM
BetaDnB
Quote:
Originally Posted by sgmfocus View Post
your right, i was just posting information for op to pass along to dealer,by reading the posts appears that they didn't tell them that the bar caused problem
If you notice, a couple key points of information were not typed into the first post.
02-13-2013 05:22 PM
sgmfocus
Quote:
Originally Posted by suss6052 View Post
In this case they have a leg to stand on as it was the op's problem was directly related to the rear sway bar causing the noise.
delete
02-13-2013 04:52 PM
suss6052
Quote:
Originally Posted by sgmfocus View Post
glad you got it fixed you should tell dealer about The Magnuson-Moss Warranty Act they can't void your warranty because of your Steeda bar,they can only deny a claim if the aftermarket parts caused problems
In this case they have a leg to stand on as it was the op's problem was directly related to the rear sway bar causing the noise.
02-13-2013 04:29 PM
sgmfocus
Quote:
Originally Posted by nerdrage View Post
Well Gene Latta Ford has said they can do nothing. My Steeda Rear Sway bar voided my warranty they say
mistake
02-13-2013 04:05 PM
nerdrage Sorry didnt update this. I loosened my Steeda sway bar and retightened it to spec. Screech is gone.

Couldnt believe it was the bar. Looking at it everything looked ok, but who knows. Weve had some wicked could weather maybe it got loose since i installed it last summer.
02-13-2013 03:53 PM
Pendarus I will bet it's loose end links on the rear sway bar. Check all the bolts with a torque wrench, don't trust they are tight, make sure they are torqued to spec..
02-12-2013 02:23 PM
BetaDnB Since you're not going to get any help from Ford I would suggest you either remove and reinstall the stock bar and bushings or remove the Steeda and regrease and reinstall. PITA, I know.
02-12-2013 02:18 PM
nerdrage i greased the hell out of them when i installed it 10k miles ago.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:38 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat