Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > MK1 Focus > Something hanging off my engine

MK1 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the first generation 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Something hanging off my engine Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-10-2013 01:26 AM
drewts86 Just whatever you do..... DON'T CUT THE RED WIRE!
02-09-2013 10:26 PM
Ssideburns I think you may be right GreenPanther. The only issue I have now is getting it reattached.
02-09-2013 10:14 PM
GreenPanther Is that on the rear of the valve cover on the passenger side? if so it should be connected to the black wire on the left of your second picture.



I think I circled what you have in the pic of my 2007. This should give you an idea of how it connects, if not I can get a closer pic.
02-09-2013 10:05 PM
Ssideburns So I have the pics here. http://imgur.com/a/28Jik

First one is of the fuse box, second is the part that is hanging. You can see the ground in the second one disconnected. I'm not really sure which fuse is fuse 9. Still new to this car stuff here :/
02-09-2013 07:51 PM
02ztsian Sounds like the ignition capacitor; check fuse 9 and see if it's blown. If it grounds it may trip the fuse. By all means tape the ends up until you replace it.
02-09-2013 07:16 PM
Blr03ZX5 any chance you could take a pic of whats hanging off? would make it easier to place
02-09-2013 06:53 PM
Ssideburns
Something hanging off my engine

So I'm not sure if this is the right place to post this, but I have a part on my '05 engine labeled 554T-18801-AC PBT-CF30 hanging off. It looks as though a ground wire has come loose from it.

Anyone here familiar with what this does? Also how bad is it to keep driving around with it not grounded?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:46 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat