Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > New CV shaft problems

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: New CV shaft problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-31-2013 03:36 PM
Joelnaf Ok great that will be my next step. Thank you!
01-30-2013 08:45 PM
rent I'll second the endlinks recommendation. My old ones (stock) looked fine but made noise when turning left-right-left. Picked up Moogs and problem is gone. Not bad for 70 bucks.
01-28-2013 10:27 PM
Joelnaf By "them" I mean outer ball joints
01-28-2013 10:26 PM
Joelnaf I checked them and they seem good. This summer I will change them and my suspension. Hopefully this helps but thinking my rack is going out. Hard spot in the steering before the pop seems to be a symptom of a rack going out.

Fingers crossed all my problems could be the upper strut mount!
01-22-2013 04:31 PM
qweesy check to see if steering rack mount bolts are loose there should be no popping or clicking, if the seal on the tranny is leaking than replace it next time you change the tranny fluid if its not too bad.

could also be swaybar endlinks ,Tierod inners and outers and ball joints check to see if they are good
01-22-2013 03:21 PM
Joelnaf
New CV shaft problems

Hey everyone so I have just replace my CV shafts and Wheel bearings on my 03 SVTF with 100000 on it. Since doing so I seem to have a few problems. When i make turns and hit a bump i get a rattling/popping sound like the CV shafts are going out. Im wondering if I received a bad shaft? Got them from PartsGeek they are EMPI and seemed to be good quality. Also the seal on the shaft to the transmission is leaking a little. Did you guys replace them?

Also when the car is stationary and I bump the steering wheel left and right I get a subtle pop like the steering rack is shifting. I will hopefully be replacing the ball joints soon to see if that solves my problem. However I still have the original suspension so that might me part of it.

Any info you can provide would be great!
Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:14 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.