Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Rough Idle and CEL Help

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Rough Idle and CEL Help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-29-2013 10:39 PM
GUM85
Rough Idle and CEL Help

I have an 02 SPI that has a rough idle issue. It started out as just a slight problem but has progressively gotten worse to the point that the car dies when stopped at a stop light because the idle drops down so low. It doesn't seem to be a problem when the engines cold but after the engine reaches operating temperature it starts to idle really rough. It has gotten so bad that when stopped at a stop light I have to keep one foot on the brake while slightly giving it constant throttle to keep the engine from stalling out. It still drives fine with no noticeable power loss. Just has problems at idle. It recently threw a code P0107 I believe "bank one cylinder too lean" I'm not sure it has anything to do with the rough idle issue. I checked for vacuum leaks but couldn't locate any. Cleaned the MAF sensor. Cleaned the PCV valve and I checked the hose that runs from the PCV valve to the intake manifold because I've heard that these engines have a problem with the hose collapsing where it meets the intake manifold and causing idle issues but the hose appears to be fine. I'm not sure what else it could be dirty fuel injector or bad o2 sensor maybe? Any help would be greatly appreciated, Thanks.

(I also forgot to add when I drive at night and I'm at a stop light and the rough idle starts I noticed the headlights and instrument lights will dim. Not sure if this is a symptom of the problem or a cause of the problem).

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:14 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat