Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > passenger side motor mount problems

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: passenger side motor mount problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-28-2013 06:07 PM
amc49 Thinking O'Reilly's really lost in their electronic catalog on Focus mounts, that problem has been there for awhile. They keep showing wrong year parts for wrong cars. They kept trying to give me incorrect parts also.
01-28-2013 11:01 AM
sailor Glad you got the right answer!

Sorry I had a "Senior Moment" and was thinking of the wrong side!

That's what comes from recently reading questions from both sides of the pond!
01-28-2013 09:47 AM
bigdhill96 yes ur exactly right mikeeshaq....u have to pry the darn thing off the bracket its like molded or pressed on and i couldnt find anyways that the new one could be mounted onto the big tower bracket....see oreillys auto part just sold me the mount itself...i need the mount with the big aluminum bracket and all....i just called the ford place and they do carry the mount with the big tower bracket and everything ready to install for the same price the parts store wanted for just the mount itself... so i will be picking it up today and putting it on after i take the part back!! thanks for everyones help
01-28-2013 09:01 AM
mikeeshaq Go to Ford and buy it there-you will get the whole thing and the mount will be of higher quality

I ALWAYS insist that the old part be returned to me. So when my daughters 2005 Focus had its passenger mount replaced, I took it apart and it was a bear to get it out of the bracket. Seems I remember I had to pry the lip up and beat on something with a huge hammer to get it out.
01-28-2013 08:03 AM
bigdhill96 no that post didnt help....mine is the passenger side....i bought the mount itself but it needs to be installed into the bracket .....i dont know how to install it ...does someone have some pics or way to do it???i have the old bracket already out but i dont see how the new mount goes onto the bracket? anyone know anything about this ??
01-28-2013 12:11 AM
sailor Check the "Driver's Side Motor Mount" thread below by "My beauticious ZX3", it has pictures & descriptions that might help answer your question.

If it doesn't help directly, referring to his pictures may help us know exactly what your issue is....

Luck!
01-27-2013 11:30 PM
bigdhill96
passenger side motor mount problems

hey everyone, i have a 2008 ford focus and have had vibration and all the mounts where shot..so i replacedthe left side and dog bone now in the process of changing the passenger side out...my problem is i have the mount and bracket out already, well whenever i went to the parts store and picked up the mount for the passenger side, it was just the mount and not the bracket.. my question is how in the world do u take this mount out of this bracket and how do u install the mount inside this bracket? do they all come this way or is it supposed to be the whole bracket and all? the part i got is Anchor 3103 is the part number...thankSfor the help
btw car is 2008 ford focus 2.0L SES automatic tranny

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:02 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat