Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Svt stalls in neutral?

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Svt stalls in neutral? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-08-2013 07:43 PM
LiciouzSVT Cleaned the IAC and the problem still persisted so I replaced it and all is good!!! I am a little mad that I replaced everything else but at least she is running perfect now!
01-27-2013 02:17 AM
LiciouzSVT Alright thanks everybody! I was begining to loose hope. I'll work on those things and keep everyone posted.
01-27-2013 01:50 AM
goinloco1 did this start after installing toms tune? if so get hold of him and let him know so you two can work on it.
try installing the stock tune and see if the problem goes away. if it does, then you know the idle needs work on toms.
if it doesn't, then it's either the iac or the tps.
01-27-2013 12:27 AM
CharlieO My car did this but only comeing down from high speeds and i did not have a code for it but i got a new tps and it cleared up
01-26-2013 05:55 PM
sleepyboy Also moved ya to the Technical Chat area for more suggestions since your having a technical problem.
01-26-2013 05:53 PM
sleepyboy SVT's do not have a EGR valve. Try cleaning the IAC though as it can get grimy from oil vapors over the years.
01-26-2013 05:51 PM
Mile30 The EGR and normal operation send burnt/spent gasses back through that portion of the intake. Carbon buildup is normal. Excess amounts of it restrict the normal flow of air; causing the engine to 'stumble'. If you want to be safe, get sensor-safe throttle body cleaner. If you are really ballsy, remove the part (if you find a lot of carbon)... and do not use brushes or scrub the stuff off! Let it dry completely before starting the car to make sure.

I'm gonna look this process up in the shop manual...

If you leave it on the car, do the job with the car running. The car will bog down a bit as the chems are burnt and passed, just stop spraying.
01-26-2013 04:07 PM
LiciouzSVT You know what I have not. How do I know if it's bad? Just a side note. 90% of the time it runs perfectly just when coasting in neutral or comepletly stoping it stalls. It only stalls maybe once or twice a week but it's enough to be annoying.
01-26-2013 03:53 PM
Mile30 Have you inspected the IACV (Idle Air Control Valve)?
01-26-2013 03:34 PM
LiciouzSVT
Svt stalls in neutral?

Okay I am pretty mechanically inclined. My dad was a mechanic in the military for over 20 years and has blessed me with the ways of the wrench. I love my car to death but it has really been aggravating me lately. Occasionally, when coming to a stop the rpms plummet and it stalls. After doing some research I cleaned the MAF, replaced the alternator and the pigtail, replaced the serpentine belt, the crank pulley, spark plugs, wires, coil pack, coil pack pigtail, o2sensor and I had the car smoked with absolutely no vacuum leaks. This car has just left me baffled. Currently the only engine mods are ORP, borla cat back, and toms tune. The car just rolled over 66,000. If you have any ideas I could really use them. I would like my car to just run with no problems for a week. Is that too much to ask for?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:10 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat