Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Forced Induction > Oh how I missed her..

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Oh how I missed her.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-26-2013 03:11 PM
ZXthrizzle05 Damn rain
01-25-2013 09:51 PM
Turbo Turtle where the maf is located doesnt matter. its where the air filter is at. if its getting cold air then its probably getting wet. turbo moves a lot of air very quickly when your in boost and sucks that water in and pushes it to the maf. it wont hurt any thing just cant really get high boost when its raining lol
01-25-2013 07:34 PM
ZXthrizzle05 Well I guess my maf was wet cuz it didn't do it today. I installed vf drivers mount today
01-25-2013 06:58 PM
Roushturboedzx3
Quote:
Originally Posted by focuzed1 View Post
probably not. i mean hell my head has over 100k miles on it the last 60-70k boosted. so im sure the stock valves are still good. Ill just get one to replace the bad one and then get a valve job and it all cleaned up good.
I made 600 on stock valves, there good
01-25-2013 06:53 PM
focuzed1
Quote:
Originally Posted by focusmaniaczx3 View Post
Man that sucks. You gonna use those valves I sent you the link for?
probably not. i mean hell my head has over 100k miles on it the last 60-70k boosted. so im sure the stock valves are still good. Ill just get one to replace the bad one and then get a valve job and it all cleaned up good.
01-25-2013 12:21 PM
focusmaniaczx3 dude just take 30 seconds to jack the car up and peek at the tranny mount. if you broke that thing and go to get into the boost that motor is going to buck hard enough for it to break vacuum lines and the intake manifold smack the firewall. ask me how i know. i just dont want to see you having more problems by breaking it worse when you can just do a quick visual first and then if its intact you can go get in the boost and see what happens.

and it might help to take a datalog as well. im sure tom would be happy to take a peek at it and tell you whats going on if you asked.
01-25-2013 11:46 AM
ZXthrizzle05 it might have gotten wet even thou it sits on the top of the engine, theres still a possibility for that. I will give it some boost today cuz there is no rain and see if problem persists
01-25-2013 10:07 AM
Turbo Turtle the bucking during rain sounds like a maf getting wet to me. mine used to do the same thing when i got in boost in the rain

Tim
01-25-2013 08:39 AM
focusmaniaczx3 Man that sucks. You gonna use those valves I sent you the link for?
01-25-2013 06:53 AM
focuzed1
Quote:
When I tested a car with the fitch inline part they claimed a higher octane with an increase in HP and TQ

On the dyno the car had about .8 to 1.2 deg knock before and after the install and made less then 1.5 HP gain which could of been from anything , showed me there was no octane increase and shown no gains in over performance in HP or TQ

Tom
When they tested it on an ls1 it produced more hp on 89 octane than the motor did with out it on 91 octane. they said that it picked up an average of 17 hp. Also the Air force uses it on all of their vehicles on the flight line. So Im not sure but Thats got to mean something.

Quote:
what was your concern with the head?
Well i went and picked up a used head hoping it would last me until i got my head rebuilt. Or at least for a little while. Well when i got the other head cleaned up I noticed some small dents/dings on one of the cylinder sections of the head (no damage to the valves so i didnt think that was gonna be a problem) Then after i got the head installed and i went to install the spark plugs. on cylinder #1 the spark plug sat lower than all the others. So i checked to make sure it didnt hit or anything and snugged it down (it was more difficult to snug down as well) I had a feeling that at some point that spark plug hole had been repaired. So my concern with it was that it wasnt going to hold boost. and I was right. so im going to take the head off again and take it back and just fix my head like i should have to begin with.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:43 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.