Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace

Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Power steering line help!!

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Power steering line help!! Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Your real name.
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-24-2013 06:37 AM
Missourileo Never apologize for car talk on here!!! I'm the op and I approve this post. My 70 had a 390 with a four speed. It was truly one of the fasted cars I've ever owned. I seriously loved that car. My grandma sold it out from underneath me when I left a set of posi marks in front of the house........ About 50 feet long.
01-24-2013 01:33 AM
amc49 I had '68 and '70 AMX and '70 Mark Donahue Javelin. My brother had a '68 race AMX that ran in the high nines 1/4 mi. His daily street driven '69 AMX ran 10.70s through the mufflers, we were a Ramblin' family.............390 and 401 rule jack. I had a 8.5/1 304 that ran high elevens. We also worked on a friends' Hurst SS/C 390 AMX. I loved that 2X4 bbl. the remains of a '70 Big Bad Green AMX sitting in backyard right now. Around here 454 Camaros were terrified of us in the mid '70s.

My apologies to the OP..........
01-22-2013 08:20 PM
Missourileo AMC parts...... I used to have a 1970 AMX...... Loved it!!!
01-22-2013 08:13 PM
amc49 Yeah, brudder, extra stuff rules. You should see my junkpile..........just used AMC parts to fix a Ford last week, maybe it'll inject a little class into that car.
01-22-2013 06:50 PM
whynotthinkwhynot Sorry dude, just got off work. I had a problem like that, but I have generic O-rings laying around from doing AC work. It's the same stuff. I'd have had you purchase a $10 multi-pack at a parts store though- LOL. Extra stuff RULES!
01-22-2013 04:43 PM
Missourileo Got the o-rings, replaced them in about 5 minutes. There are two of them in the quick disconnect. Inspected the rest of the line and it is perfect. O rings were 6 bucks. Thanks for all the smart ass comments. All I wanted to know was whether or not there were o rings inthe disconnect. The how to didnt show that. Problem solved.
01-22-2013 11:15 AM
Missourileo Just got off the line with the stealership. He said the techs recommend replcing the o-ring(6 bucks) versus the entire line. I want to get the new line, just need to make it around until it comes in. Everywhere I've called, it takes two to three days to get. It IS SVT specific as well. That's why I was asking about the o-ring.
01-22-2013 10:43 AM
elsolo Yes, there is an O-ring.
No, I would not recommend replacing just the O-ring.
01-22-2013 10:31 AM
wickedgreyzx3 Go to the dealer and get the line and the o ring. If you're driving a ten year old car it makes no sense in pulling something apart to replace a 5 cent o ring.
01-22-2013 10:28 AM
Missourileo I read this already and not helping.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 01:45 AM.

Copyright 2002-2015 All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.

Search Engine Optimization by vBSEO 3.6.1