Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Wheels & Tires > Hey, hey, whats that sound?

Wheels & Tires The place to go for answers on wheel types, tire sizes, offset, wheel patterns and more.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Hey, hey, whats that sound? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-20-2013 04:42 PM
Ender92 When my 04 lx did this replacing the front sway bar links took care of it.
01-20-2013 02:35 PM
josephd Sounds like the strut to me. Usually ball joints or the links will clunk when they go bad.
01-20-2013 02:30 PM
focusonthefocus19 I've been having the same problems. Kind of like nails on a chalk board sound. If you know what the problem is please let me know.
01-20-2013 12:12 AM
Sully313
Hey, hey, whats that sound? (Suspension noise + Video)

Got a noise in the left front of my 03 SVT. Creeks over bumps and turning. It does not make noise when the suspension is unloadad. the Outer tie rod has been replaced so I greased it and it resulted in no change. I can't tell if its coming from the Ball Joint, end link or the strut.

I'm hoping this will sound familiar to someone.

Click image below for video.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:51 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1