Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > Damaged coil packs!

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Damaged coil packs! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-18-2013 10:32 AM
nilskje Replace the plugs and the wires & the coilpack at the same time, use the Ford HT cables and make sure you get the upgraded coilpack unless you already have this also, chk the connector that goes to the coilpack with the 3 wires the a prone to breaking. Guess a new coilpack lasts only for a little while?
01-18-2013 06:55 AM
Classic6200
coil

Hi. I recently changed out my coil pack to the ACCEL brand as it was less expensive and I also had isssues with a stumble.

Came to find out that the plug that connects to the coil pack had one side tab broken and this allowed vibrations to cause the misfire.

I used 2 zip ties to cinch the plug to the coil pack and problem solved
01-14-2013 11:22 AM
Gotch26
Damaged coil packs!

Hi, this is my first post and I'm looking for some advice.

I live in the UK and own 2007 ford focus. In the last 6 months it has developed a reoccurring fault with the coil pack. I have replaced it 3 times and still have a problem.

Can anyone tell me if this a common thing and if so, how can it be resolved.

Thanks in advance

Gotch26

P.s some mentioned to me the wiring between ecu and coil pack!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:12 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.