Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > 2008 FF SE rear defog not working

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: 2008 FF SE rear defog not working Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-09-2013 08:12 PM
*MiCHELiNAs*FF fuse is OK... but does anyone know anything about a fuse relay? that might be my issue
01-09-2013 05:15 PM
*MiCHELiNAs*FF fuse is fine- well...i had someone else check for me, so i guess i should double check myself first LOL
01-09-2013 02:36 PM
misfire
Quote:
Originally Posted by SkyPilot View Post
First check your connection again.

and check the fuse box under your hood, according to the owners manual its fuse #2 and its a 30A fuse. if it looks blown then replace.

Owners Manual <look at page 173 for fuse box diagram
agreed
01-09-2013 01:14 PM
SkyPilot First check your connection again.

and check the fuse box under your hood, according to the owners manual its fuse #2 and its a 30A fuse. if it looks blown then replace.

Owners Manual <look at page 173 for fuse box diagram
01-09-2013 11:54 AM
*MiCHELiNAs*FF
2008 FF SE rear defog not working

So LAST winter my rear defogger stopped working due to the connector coming off of the window. I resolved that by applying new conductor solution and sticking it back on the window which was fine. This winter it does not work again but it is still connected- any suggestions? I don't want to have to replace the entire windshield and all the grids look to be in perfect shape?? help!

Thanks! =)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:14 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1