Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Brakes, Suspension & Body Chassis > positive camber after installing coil overs

Brakes, Suspension & Body Chassis The place to go for answers on brakes, suspension, camber, alignment and more.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: positive camber after installing coil overs Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-08-2013 10:13 PM
israel
Quote:
Originally Posted by sleepyboy View Post
So you didn't get a alignment done with them? They usually don't come with upper camber plates that's a separate part I think? Did you replace the upper strut mounts?
I did but i dont have the sheet, oh ok i thought i was ripped off for a second lol, no but i will take a look at that.
01-08-2013 10:02 PM
sleepyboy So you didn't get a alignment done with them? They usually don't come with upper camber plates that's a separate part I think? Did you replace the upper strut mounts?
01-08-2013 09:53 PM
israel
Quote:
Originally Posted by sleepyboy View Post
How much positive camber do you have? Do you have an alignment sheet from the alignment? Did you replace your sway bar links as well at the same time? Those are known to cause the popping noise though wouldn't have anything to do with the positive camber issue. Does it have upper camber plates on the coil overs? If not then I would try those out to dial it in where it needs to be, that's if everything was installed correctly.
its not too much of positive camber but i can tell there is some, yea sway bar link and ball joints were replaced at the time the coilovers were installed, umm no i bought them used n didn't come with that....could that b the problem?
01-08-2013 09:35 PM
sleepyboy How much positive camber do you have? Do you have an alignment sheet from the alignment? Did you replace your sway bar links as well at the same time? Those are known to cause the popping noise though wouldn't have anything to do with the positive camber issue. Does it have upper camber plates on the coil overs? If not then I would try those out to dial it in where it needs to be, that's if everything was installed correctly.
01-08-2013 09:28 PM
israel it is lowered, no wheel gap in the front, and about half an inch wheel gap in the back
01-08-2013 09:26 PM
sleepyboy He had a shop do it. Is it lowered any or still at the stock height?
01-08-2013 09:23 PM
6SPD_soul You might have to progress from lolspeak to get any meaningful response here, but I'm going to say something is very wrong if you somehow ended up with positive camber after lowering you car. Talk to the Texans that installed your suspension because if you got positive camber they did something terribly wrong.

ok like the tittle says
01-08-2013 08:51 PM
israel
positive camber after installing coil overs

ok like the tittle says

i just got coilovers installed (ksport kontrol pro) but there's an issue, i have a little of positive camber instead of negative.
also there is a popping noise coming from the front driver side and it is not the ball joints because that was replaced at the same time the coil overs were installed.
any ideas whats going on here?
thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:08 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.