Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > battery light issue

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: battery light issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-31-2012 06:47 PM
mddunlap03 ok the car was reading 14.3v at idle replaced alt never breaks 14v but light is off so yey lol
12-31-2012 12:36 PM
mddunlap03
not the connector

pulled apart and cleaned wires look good still have the light with all the acc on and load tester at a 100amp at idle it drops to 12v with no tester 13.5 - 14.8 idle /2000 rpm lost on this one found a broken wire on valve cover going to a small black box maybe a 14-16 gauge wire both black one goes to ground other into a harness my guess is its a superuser for injectors or coil ? any one ?
12-31-2012 11:07 AM
svtguy88 Check the 3-pin (I think) going to the alternator - notorious failure point that will give you a battery light. The wiring to the connector or the connector itself are common parts to break. Took me forever to find it when it happened to me.

If that's the problem, you can get a harness repair kit and solder on a new section of wire/connector.
12-31-2012 11:05 AM
mddunlap03
battery light issue

so my charging system light is on. turns on after running for a bought a minute. batter checks out good on load tester (mine does not have an amp probe :( . with car running voltage is 13 + volts at idle at 2000 rpm under load is 14-14.5 . plz help

also are i have heard these are clutched i dont think that to be true but is it ?

mod Big 3 wire upgrade, fs werks 2.5 cat back, zx 500.1 amp x2, k and n on maf tube

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:54 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat