Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > 2000 Focus Vents Stuck?

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: 2000 Focus Vents Stuck? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-23-2013 02:17 PM
2000FFocusLX
Quote:
Originally Posted by Focusblackzx5 View Post
same thing on my 05. I have to turn the button very hard to change the ventilation direction. Same thing on my previous 03. It's a current problem on Focuses.
Yeah idk why maybe things get stuck back there, I took someone's advice and took out the glove box to see if I could see behind where the blend doors are but No just the blower motor.
12-28-2012 05:43 PM
Focusblackzx5 same thing on my 05. I have to turn the button very hard to change the ventilation direction. Same thing on my previous 03. It's a current problem on Focuses.
12-28-2012 04:14 PM
2000FFocusLX Hm. That's how mine was before it got stuck on defrost. I'm betting something is blocking the vents from changing
12-28-2012 03:23 PM
mark315 I can get 2 positions. Defrost and vent. No heat at floor, no defrost/heat mix.
12-28-2012 03:07 PM
2000FFocusLX
Quote:
Originally Posted by mark315 View Post
I have the same problem with my '07. I replaced the Bowden cable. The upper blend "lever" that is part of the heater box works fine. However the lower blend lever is stuck. Does anyone have steps to access the heater box so I can remove the obstruction? I'm not sure blowing air in through the blower motor opening will work as it seems pretty far away from the problem area.
Thanks
Is yours stuck on defrost also?
12-28-2012 02:54 PM
mark315 I have the same problem with my '07. I replaced the Bowden cable. The upper blend "lever" that is part of the heater box works fine. However the lower blend lever is stuck. Does anyone have steps to access the heater box so I can remove the obstruction? I'm not sure blowing air in through the blower motor opening will work as it seems pretty far away from the problem area.
Thanks
12-28-2012 02:35 PM
2000FFocusLX
Quote:
Originally Posted by rsnow View Post
yes they are cables, check the selector cable, may be stuck, look where it attachs to the blen door box

I already snapped the cables, when I was replacing them I tried manually changing it with the selector down by the blend door box on the outside, and the thing will not turn at all... The cables are not the problem. I already snapped and replaced them. The problem is whatever is behend the switch Which I have no idea how to check or anything.
12-28-2012 07:31 AM
rsnow yes they are cables, check the selector cable, may be stuck, look where it attachs to the blen door box
12-28-2012 05:07 AM
whynotthinkwhynot Focus vent selectors are controlled by a cable, not vacuum. Be thankful, vacuum actuated controls are not fun to diagnose problems on.
12-28-2012 01:21 AM
2000FFocusLX Thanks for the reply! That does help out, but he didn't completely specify. It might be a vacuum leak I'm thinking.. because it is stuck in defrost.. I'm going to pull the glove box off tomorrow and see if I can find out if anything is blocking the vents, I hope so. Because I have no idea what I'm doing. Anyway, more help would be appreciated.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:41 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.