Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > 2002 ZX3 - Clutch Beelding Problems

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: 2002 ZX3 - Clutch Beelding Problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-06-2012 01:50 PM
xxMichaelAnthony Slave. Had the same thing happen in my Ranger. Slave was a year old, didn't replace the master when I got the clutch done and both went out.
12-06-2012 01:49 PM
Buddy4679 did u bench bleed the master before putting it on?
12-06-2012 01:43 PM
MK3_TX I would check the master again if your getting air in it ,even though it may be new it could very well be no good
12-06-2012 01:40 PM
MK3_TX I would consider one of them faulty.
12-06-2012 12:55 PM
mikerob97 master is new, slave is 1 year old.
12-06-2012 07:05 AM
MK3_TX Sounds like either your master or slave cylinder.
12-06-2012 06:54 AM
mikerob97 Bump - No one else has experienced this with their focus?
12-05-2012 08:43 AM
mikerob97
2002 ZX3 - Clutch Beelding Problems

Here is the problem:

Replaced a fail master cylinder that was leaking. Bleed the system until clutch pedal felt firm, used a pressure bleeder. After a day or two of driving, the pedal starts to get soft. I can pump the pedal to get the pedal firm again, but then will get soft after a few more miles. I have bleed the system several times, but this cycle continues. There are no visible leaks under the bell housing from the slave or the master and the fluid level in the reservoir stays full. Note - the slave cylinder is less than two years old - I replaced it when I replaced the clutch.

Any thoughts on this? I am a fairly experienced home mechanic and have worked on many cars through out the years and bleed many a clutch on VWs, BMWs and Hondas. I have never had a clutch pedal fail on the road after bleeding it.

Thanks in advance for any replies.

Mike in Cary, NC

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:13 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat