Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics > amp/speakers or new HU

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: amp/speakers or new HU Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-10-2012 05:10 AM
austinpetemo Ive been noticing alot of alternator whine. Is this due to the small power cable that is currently being used? I tried putting a bigger ground cable to the HU to see if maybe by some chance it would help but no dice. would the big 3 fix this?
12-05-2012 10:10 PM
freemind
Quote:
Originally Posted by austinpetemo View Post
Ok so when I pulled the head unit forward I accidentally pulled out a connection in the back. Redid everything and it came on. Up next will be a better HU and thicker power/ground. I'm thinking 2awg to a distributor and then 4awg to each amp will work. When I get a better sub amp I still won't be running more 600w through it. I think what I have right now is like 6-8 and prolly not true copper. I made sure to get true 14awg 99.9% copper wire for my components but I just used power cable I already had installed.
You cannot go wrong here, http://www.knukonceptz.com/

Easy on the wallet as well
12-05-2012 08:10 PM
austinpetemo Ok so when I pulled the head unit forward I accidentally pulled out a connection in the back. Redid everything and it came on. Up next will be a better HU and thicker power/ground. I'm thinking 2awg to a distributor and then 4awg to each amp will work. When I get a better sub amp I still won't be running more 600w through it. I think what I have right now is like 6-8 and prolly not true copper. I made sure to get true 14awg 99.9% copper wire for my components but I just used power cable I already had installed.
12-05-2012 06:53 PM
freemind Good man!
12-05-2012 06:31 PM
austinpetemo Just ripped out my HU and hooked it up to a 12v battery and it came on just fine. Guess I need to check all the connections.
12-05-2012 06:23 PM
austinpetemo Ya, probably a boneheaded move on my part. The amp and speakers are fine but I fear my HU may be toast. I'm surprised its lasted as long as it has, crappy dual.
12-05-2012 06:21 PM
freemind You swapped the RCA's with the power on?
12-05-2012 06:07 PM
austinpetemo Everything arrived and has been installed. I put my crossovers on the kick panel and the tweeters in my a pillar but ran into a problem, my tweeters are too deep and don't fit so I'm going to have to figure something out. It was to bright at first so I adjusted the tweeter to -3 on the crossover and it made it sound much better. Then I realized my RCA cables were backwards on my head unit so I pulled them off and plugged them back in. My radio now won't turn on and I'm not sure why. Fuss number 31 was blown so I swapped it. Got the radio to turn on for a minute but now it's off again and won't turn on again. Hope I didn't blow it.
11-23-2012 03:23 PM
austinpetemo Hooked up some home speakers to my small sub amp to see what amped doors would sound like and decided to go that route first instead. Got a set of pioneer 1720comps on the way and 4 chan polk 660 to run them. Did some more research on the kappas and polk DBs and found that these were supposed to be superior to both in highs and the mids.

Next on my list however is to upgrade to that JVC HU in a few months and then perhaps get a second set of components in the future.
11-22-2012 06:37 AM
doubles IMO that is what i would do as im thinking of doing it in my 08 focus a doubledin with bluetooth nav and siruis a kinda all in one then do speakers last
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:08 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.