Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace

Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Cooling Fan Won't Turn Off

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Cooling Fan Won't Turn Off Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Your real name.
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-16-2012 08:45 AM
Methos65 Thanks for responding. After a quick google search, they seem cheap enough. I'll swap it out and see if that fixes the problem.

Thanks for the help!
11-15-2012 09:02 PM
elsolo Yeah, my first guess is one of the two fan relays is stuck.
11-15-2012 08:59 PM
iminhell Sounds like a relay went bad ...
11-15-2012 03:40 PM
Cooling Fan Won't Turn Off

I have a 2004 ZX3 manual with about 85k miles on it. Recently, the cooling fan won't turn off when I turn off the ignition and ends up draining the battery. I have been unhooking the battery to get it to turn off. However, wifey doesn't like popping the hood everytime she uses the car. . So I need to fix this problem. If I unplug the battery for a little while and let things cool down a bit, I can hook it back up and the fan won't come on.
A/C has not been turned on and I see two fans behind the radiator. Both are on even after the ignition is turned off.

Can anyone suggest where I might start looking to fix this problem?

Thanks for reading.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 10:10 AM.

Copyright 2002-2015 All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.


Search Engine Optimization by vBSEO 3.6.1