Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Ford Focus 2005 Power Problem

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Ford Focus 2005 Power Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-08-2012 02:44 PM
burnsy5shoes
Ford Focus 2005 Power Problem

Hi there, wondering if anyone could help, I'm based in Glasgow and have been having problems with my ford focus 2005. I bought the car used but have had no end of problems. The coil pack on the car has been changed 4 times. Once the coil pack was full of water and I found out that it was due to rainwater entering through the bonnet as I had faulty windscreen washers. A new coil was fitted but engine light came on after a week. Took it to my mechanic and hooked up to diagnostic machine. Showed a problem with coil. So I bought a new coil and also new rubber leads, these were fitted two days ago but engine light came on today and it seems like the same problem of lack of power when I am driving. I recently had my cylinder head gasket re-skimmed but think this is in-related. Further interesting thing was when the coil pack was replaced a few days ago, the courier delivered it and said ' coil pack for ford fiesta mate?' And I said no, focus!! But my mechanic fitted it as he said its the right one. I'm at a loss as to why I have to keep replacing the coil pack and car continually has no power. Please help!!!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:16 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat