Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > MK1 Focus > 2000 Ford Focus mileage getting worse

MK1 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the first generation 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: 2000 Ford Focus mileage getting worse Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-27-2012 09:22 AM
gello88 Exaust seems fine. Didn't get the chance to check the O2 sensors but my mechanic brother diagnosed it and the two sensors seem to operate normally. He says that the car is no timed properly. When he diagnoses it using his OBII device, he sees the car has an ignition timing of over 30 degrees from top dead center and that's when the car is in idle (parked not moving) and he says it should be much lower than that. Anyway, he did a vacuum test too and the engine is good. Sprayed the MAF sensor cleaner stuff too and the car did feel more responsive and better at acceleration, can't say anything about the mileage yet though
10-26-2012 03:58 PM
FLZ_Boy Any exhaust leaks? Have the O2 sensors been replaced recently?
10-25-2012 10:45 PM
gello88 Ya seems weird but oh well. Gas mileage still sucks currently but it's gotten better than my first 1/4 tank. Spark plugs are gonna be checked and MAF sensor will be cleaned out. Just waiting to get some time in my hands. I kinda suspect the gas that my mom put in it when she borrowed it. It was Petro-Canada, I've always used Shell gas and almost always had normal to good mileage with it. Just gonna burn this tank to empty and re-fill with my usual Shell and see what happens :D
10-25-2012 10:39 PM
Notorious0ne Ive seen really random shit, I work at an autoparts store and this guy came in the other week where the dealership figured out that the one fuel injector was occasionally getting stuck open. Didn't happen all the time but it did sometimes. Id do some more research though first.
10-24-2012 10:28 PM
gello88 Really? Logically speaking, that may explain the random excessive fuel consumption. I didn't knw fuel injectors can get stuck open.
10-24-2012 10:15 PM
Notorious0ne Its rare but maybe a fuel injector got stuck open?
10-24-2012 07:08 PM
gello88 Thanks, the fuel filter is also new. Replaced just 4 months ago. I'm still on the same tank of gas actually and the fuel economy has actually gone back to "normal" more or less. I only used up a little less than 1/8 of a tank for the same distance (40km). I still don't know why I sometimes I get freaky gas mileage (burning fuel at a ridiculously high rate) then going back to normal the following day ...
10-24-2012 05:53 PM
freemind Fuel filter ASAP
10-24-2012 05:00 PM
gello88 I'm actually going to check the spark plugs today. Come to think of it, the spark plugs havent been replaced for at least 2 years ... the car was a hand me down. I already did a fuel treatment a few weeks ago so I dont wanna do that again, it's bad to overdo those things.

Ya, the gas prices here in Toronto have dropped significantly lately and that's partially due to their switch to the "winter" gas. As for the oil, I just had an oil change and I use synthetic oil only.
10-24-2012 11:16 AM
Notorious0ne There are a couple things you should try, Might be a good idea to change your spark plugs. If you can get some Lucas fuel treatment toss some of that in there It should help clean out the fuel system. Also we are getting to that time of the year where places are switching to their winter gas which makes our gas mileage suffer. Also what kind of oil are you running? Synthetic or non synthetic.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:39 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat