Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > sluggish from idle to 2000rpms

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: sluggish from idle to 2000rpms Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-12-2012 01:46 AM
freemind Did you replace the PCV valve?
10-11-2012 06:58 PM
alaskanzx5
sluggish from idle to 2000rpms

so i have read through several threads and i think i know what the best possible answer is for my issue but i will ask anyways as to the fact that i dont have much money right now so i cant realy be playing the guessing game.

when i first start the car and put it in drive then get on the gas it feels like it just doesnt want to go but then when it hits 2000 rpms it runs fine. while driving down the road around 2000 rpms it has a very slight stumble to it.

i have checked all the hoses and replaced the pvc hose because it was collapsing on itself, the problem got better for a few weeks but then the car went right back to what it was doing. checked the hoses agian and they are all still fine.

my bet is on the egr, but i do have a tps that im gonna put on the car. it is the stock tps, baught a used cfm throttle body with tps sensor and so i still have my stock one.
if the tps doesnt fix it then is my next step the egr valve?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:37 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.