Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Just need some advice.

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Just need some advice. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-11-2012 11:02 PM
03FocusZX3 Thanks a lot, I'll have to check into that, and yah mine has chattered since I've got it, which was in 09 with 66k miles, just finally got annoyed enough to ask.

Sent from my HTC ThunderBolt using FF Mobile
10-11-2012 05:22 PM
matmatician The chatter may actually be the tumble flaps on your intake manifold. Mines was making similar noises until I got mine replaced. But yeah, there is a bit of vibration on warm up with mine too, I wouldn't worry about it too much.
10-11-2012 04:15 PM
boardgeneration My 05 ZX3 also makes that sound on startup. Kinda loud and annoying but stops after maybe 20 seconds or so. I bought it at 73k and with 89k now the sound is the same as it was when I got it. I'm guessing thats normal.
10-11-2012 11:40 AM
1turbofocus Find a local member with a xcal and do a datalog , this will tell you what the sensors are reading and if you have any issues happening

Tom
10-11-2012 08:36 AM
03FocusZX3
Just need some advice.

So, I've replaced all my motor mounts, car is tuned up, replaced fuel filter etc, but in cold weather my focus likes to vibrate, not significant, but enough to make the hatch rattle, and is buzzy pushing the gas when only driven for about 10 min. Wondering what else this could be, or is this normal? And as long as I've had the car, when I first crank her up, I can hear the valves chattering, kinda sounds almost like a slight knock, but goes away after about a minute of running. Annoyed by these little things. If anyone has any insight I would greatly appreciate it. Thanks

John

Sent from my Thunderbolt using FF Mobile

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:40 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat