Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 TSB, Recall & Problems Archive > NO indicator for winshield wiper fluid

MK3 TSB, Recall & Problems Archive The place to chat about TSB and Known Issues for the 2012 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: NO indicator for winshield wiper fluid Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-10-2013 04:47 PM
Tiger-Heli
Quote:
Originally Posted by Cubedtothex View Post
now I know that they don't perform TSBs unless you ask for them. My transmission works and doesn't grind, etc. so I don't want them touching it now.
Not necessarily true. I've known people to take a car in for an oil change and the dealer ran the VIN and found and ran a TSB for them.

That said, I'm not sure that I would be worried about taking the car in and telling them you JUST wanted the WW Fluid TSB done and not to mess with the tranny.
12-10-2013 04:41 PM
Cubedtothex Well that explains everything. I got a Nasty surprise one day when mine ran out! No chime, no indicator, no nothing! I never knew it was a TSB....now I know that they don't perform TSBs unless you ask for them. My transmission works and doesn't grind, etc. so I don't want them touching it now.

ON SECOND THOUGHT: I just got my Criuse Control fixed....I'll survive as I always carry extra Fluid with me anyway. It seems like the taks is smaller than previous Foci. My 2007 was a bottomless pit and could take almost 2 standard jugs!
06-01-2013 06:00 PM
royce20002006 Mine has it it is in the middle computer screen it comes on for a brief second then is in system check and it comes back on when you turn the car back on at certain times
05-22-2013 07:28 AM
lewisra
Quote:
Originally Posted by Strix View Post
The sign that they are going to do it wrong is the blue oval out front.
I'm happy with my dealer.
05-21-2013 06:40 PM
Strix
Quote:
Originally Posted by NorthernFocalPoint View Post
I guess my dealer being surprised that there was an update and having to attempt programming the MFT system 3x because they said it kept rebooting was probably a sign that they were going to do it wrong.
The sign that they are going to do it wrong is the blue oval out front.
05-21-2013 06:07 PM
dyn085 Moved to MK3 TSB, Recall & Problems Archive.
05-21-2013 05:25 PM
sprcoop I had my low fluid warning fixed at my last oil change (6K miles ago). I had to tell them about the TSB but they got it done. It feels like they did the "tip in" for the throttle also because I don't have to be as careful with the clutch as I did before.

The warning comes on a few seconds after you start the car, not a dummy light. Great big message and accompanying "ding!". I got 5 or 6 windshield washes (front and back) after the warning. Never did run out before I refilled.
05-21-2013 04:43 PM
NorthernFocalPoint So, I'm not sure my dealer applied the update in the TSB or did it incorrectly. Was driving back over the long weekend here, waiting for the indicator to come on because I was using quite a bit on the bugs but never got a warning, so figured I must still have quite a bit in the reservoir.
At the service station, I filled up the gas tank, squeegeed the windshield and then was driving off to get back on the highway when I decided to give it one more spray/wipe.

No fluid and no warning. Quickly pulled over while still at the service station grounds and filled the empty reservoir.

I guess my dealer being surprised that there was an update and having to attempt programming the MFT system 3x because they said it kept rebooting was probably a sign that they were going to do it wrong.
03-08-2013 02:38 PM
Some Guy From NY
Quote:
Originally Posted by NorthernFocalPoint View Post
Well, to be honest, I helped them out (or I should say you folks here helped me out), since I was able to spoonfeed them the TSB no.

A little concerned about this dealership since they had no indication on their system that 2 recalls and an MFT update which were applied the week before, had been done and at first implied in their tone that I was being negligent by not having them done when they were done by this dealer (and it took them 3 tries to do the mft update which I had initially told them I would do myself - I had no trouble when I did it last year)!!

When I got the TSB done, I was also changing my oil (I brought my Motorcraft syn. blend which I bought in the US because this dealership only offers reg. or full synthetic and doesn't stock syn. blend even though that's what the focus comes with from the factory) and left the jug in the front passenger foot area and the serviceperson even left a note on the work order, yet when the car was ready, the serviceperson realized that the syn. blend oil I supplied was never touched (to his credit he offered to have it drained and refilled with mine in 7 min. but understand that I'd already been waiting there for 2.5hrs to have the oil change and TSB applied even though I had an appt.).

Love the car, not so much the servicing.
Hilariously coincidental story I have. This last Wednesday, I went to a dealership that I think messed up the install of my steering rack for them to give me a printout of the work orders associated with it.

First, after they installed the new rack, they messed up the alignment so a week later I had to bring it back for them to correct the alignment. They had no paperwork showing this was done.

While I was there waiting for them to printout the paperwork they did have, a woman was leaving after getting an oil change. A tech walked her to her car, then immediately came back in to talk to the service manager who was helping me. The tech says the oil the woman had brought in herself, which was a full synthetic oil was still in the car. The service manager looks at the work order which he had given the tech who did the oil change and it clearly in black marker, written almost across the entire order was USE CUSTOMER PROVIDED OIL & FILTER. But nope, apparently the tech had just put in regular(most likely syn blend) oil and not even looked at the work order. They had the woman come back in and they were going to change the oil again using her full synthetic oil.

Ford dealers here in the US I think now only use synthetic blend oil now. Weird how they still use regular and don't even carry the blend in Canada. Well in your dealership anyway.

What is wrong with the service departments?

No one gives a shit about doing their job anymore. I am so sick of dealing with these people.
03-08-2013 02:22 PM
NorthernFocalPoint Well, to be honest, I helped them out (or I should say you folks here helped me out), since I was able to spoonfeed them the TSB no.

A little concerned about this dealership since they had no indication on their system that 2 recalls and an MFT update which were applied the week before, had been done and at first implied in their tone that I was being negligent by not having them done when they were done by this dealer (and it took them 3 tries to do the mft update which I had initially told them I would do myself - I had no trouble when I did it last year)!!

When I got the TSB done, I was also changing my oil (I brought my Motorcraft syn. blend which I bought in the US because this dealership only offers reg. or full synthetic and doesn't stock syn. blend even though that's what the focus comes with from the factory) and left the jug in the front passenger foot area and the serviceperson even left a note on the work order, yet when the car was ready, the serviceperson realized that the syn. blend oil I supplied was never touched (to his credit he offered to have it drained and refilled with mine in 7 min. but understand that I'd already been waiting there for 2.5hrs to have the oil change and TSB applied even though I had an appt.).

Love the car, not so much the servicing.

Quote:
Originally Posted by FordCustomerService View Post
I'm glad to hear that your dealer helped you out, NorthernFocalPoint! Let us know if the warning message pops up in the future; keep in mind I'm always here to help if you need me.

Crystal
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:08 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat