Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > Head light help needed asap!!!

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Head light help needed asap!!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-15-2012 04:23 PM
gtford86 ours are being weird to they dont work but if u hit the light they go on... i changed the actual switch 1 time(junk yard part) they worked for a while now stopped again...waiting for a new one to come in to test my theroy
09-25-2012 02:56 AM
the-beast
Head light help needed asap!!!

Hi guys my main beams arent working on my focus, i'll give you the full story, started off my stereo turned itself off a couple of times whilst i was driving (had the music at the max so presumed it could be that) then parked up and before i was going to leave turned the lights on and a bulb blew (drivers side), didnt think anything off it and decided to change it when i got home, changed it and its still not working. tried the passenger side bulb init as i know that was working, still didnt work and now the passenger side doesnt work, i've tried the fuses and relays and swapped a working relay around, the bulbs don't look blown but could be i suppose it could potentially be that, has anyone got any other ideas as i'm completely stumped, any ideas would be much appreciated, i have also checked the wires on the back of the switch and they look ok. thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:30 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.