Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > DURATEC Performance (2003-2007) > spectre kit help

DURATEC Performance (2003-2007) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: spectre kit help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-12-2012 02:24 PM
boardgeneration Nice. Yea I'd make sure that clamp is on a bit better. Could vibrate off. Looks good tho!
09-11-2012 08:12 PM
sam fisher
finnaly got the pics to work , heres a shot of the bottom of the cai

[IMG][/IMG]

if look youll notice the clothes hanger i used to support it , lol it worked real nice actually

it looks like the fastner wants to slip off the coupler tho
09-05-2012 08:19 PM
boardgeneration Or just use tapatalk mobile app and take photos right from the phone to the post. That's usually what I do.
I only use the Internet site while I'm at work! Haha.
09-05-2012 08:09 PM
boardgeneration The stock maf tube clamp fit correctly the way I set mine up.

As for posting images, take ur pic. Upload it to photobucket. Click on the pic once it's on photobucket and copy/paste [IMG] URL to ur post. That's it.
09-05-2012 12:33 AM
sam fisher also , do you have anything supporting the setup or is it free-hanging? im not sure how im going to support mine
09-05-2012 12:32 AM
sam fisher
Quote:
Originally Posted by boardgeneration View Post
I used my stock maf tube. However the top section of it was over 3" and I couldn't fit the coupler over it.
I took a dremel to the section of the maf tube that holds a honeycomb screen. I cut off a total of maybe two to three inches. If u look at the stock tube you will see there is plenty of tube to couple onto if u cut that top wide section off. However there's no reusing it on the stock air box obviously.
just did that , i would post the pics but i have no idea how to do that on here , when i click insert image it tells me to type in a g url .
09-04-2012 10:20 PM
boardgeneration I used my stock maf tube. However the top section of it was over 3" and I couldn't fit the coupler over it.
I took a dremel to the section of the maf tube that holds a honeycomb screen. I cut off a total of maybe two to three inches. If u look at the stock tube you will see there is plenty of tube to couple onto if u cut that top wide section off. However there's no reusing it on the stock air box obviously.
09-04-2012 08:26 PM
sam fisher i still have to finish it so i will try to take some pics to post up
09-04-2012 08:25 PM
sam fisher
Quote:
Originally Posted by boardgeneration View Post
I bought the spectre kit and used 3" couplers they had at autozone. Worked fine for me.
i also see that in your pic your maf tube looks to be a little smaller than mine because i have the same couplers and its just too small , edit: wait did you even retain your stock maf tube , now that i look harder , is the maf going into the kits tubes? i am going to keep my maf tube .
09-04-2012 08:24 PM
sam fisher
Quote:
Originally Posted by boardgeneration View Post
Oh shoot! Yea I actually cut the wide part of the maf tube with the honey comb off and coupled it onto the spectre kit. Sorry I forgot about that.
good stuff , see i dont know why but the 3 inch spectre coupler was just too small , i tried boiling it and forming it around the maf tube , and i also tried a heat gun , the thing just would not budge .
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:34 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat