Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > DURATEC Ti-VCT Performance (2012-Current) > Those with Magnaflow's Exhaust System (Part #15072)

DURATEC Ti-VCT Performance (2012-Current) The place to chat about any Duratec 2.0L Ti-VCT engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Those with Magnaflow's Exhaust System (Part #15072) Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-14-2015 11:56 PM
dchawk81 Or at least run like a car.
10-14-2015 10:00 PM
Gi_Jo_Nathan Wow. Should run like a new car now.
10-14-2015 09:07 PM
Sanforized
Quote:
Originally Posted by PrDawg View Post
That SUCKS. Need a cat in your air box. lol
Yeah, I just cleaned it out thoroughly. I got this car in the beginning of August this year with around 51,000kms on it, so it could've been from when the previous owner had it.
10-14-2015 08:56 PM
PrDawg
Quote:
Originally Posted by Truth in Ruin View Post
It looks like PrDawg's avatar got into the intake.
Yup. Had to eat the competition. LOL
10-14-2015 08:52 PM
Truth in Ruin It looks like PrDawg's avatar got into the intake.
10-14-2015 07:18 PM
PrDawg At least they eating filter and not wiring. Now gotta find a fix.
10-14-2015 07:16 PM
PrDawg
Quote:
Originally Posted by Sanforized View Post
I added a K&N drop in filter into my car. I was going to go down the same route you went and get a CAI, but I found something in my intake yesterday that was quite alarming.




That SUCKS. Need a cat in your air box. lol
10-14-2015 06:34 PM
Sanforized
Quote:
Originally Posted by PrDawg View Post
Yea. They loosened my subframe also but left the heatshield in place. Removing the unneeded hanger was enough to clear without removing the shield. Does sound good. Even better once I added the Steeda CAI.
I added a K&N drop in filter into my car. I was going to go down the same route you went and get a CAI, but I found something in my intake yesterday that was quite alarming.




10-14-2015 05:41 PM
PrDawg
Quote:
Originally Posted by Sanforized View Post
I brought it into the shop to get it fitted after I cut the OE one off. It's a miracle I didn't get a ticket for driving without an exhaust. They loosened the subframe and removed the heat shield to get the midpipe over the rear axle. No need to cut any hangers. It sounds great now.
Yea. They loosened my subframe also but left the heatshield in place. Removing the unneeded hanger was enough to clear without removing the shield. Does sound good. Even better once I added the Steeda CAI.
10-14-2015 01:01 PM
Sanforized
Quote:
Originally Posted by PrDawg View Post
Quote:
Originally Posted by Sanforized View Post
I hate to bump such an old thread, but I tried installing this exhaust today and I can't seem to get the midpipe over the rear axle. I tried it multiple times from both directions but no luck. Does anyone have any insight into this? :(
They did mine the other day. That piece has 2 hangers. Look at the original it only has one. We had to cut the second one off.
I brought it into the shop to get it fitted after I cut the OE one off. It's a miracle I didn't get a ticket for driving without an exhaust. They loosened the subframe and removed the heat shield to get the midpipe over the rear axle. No need to cut any hangers. It sounds great now.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:44 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1