Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Performance (2002-2004) > O2 sensors new / check engine

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: O2 sensors new / check engine Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-30-2012 04:49 PM
whichdoctorbilly? suggest getting motorcraft plugs. bosch just dont wanna fit
09-11-2012 10:46 PM
jmoryl
Quote:
Originally Posted by 1turbofocus View Post
I dont agree , I get ALL my o2 sensors from Advance or autozone , they also give a 1 year warranty and you dont have to ship it back to tously for the warranty , Ford also gives a 1 year warranty so I would ask tously if they offer that as well they should

If you think you have a short then replace the fuse WITH OUT the the o2 pludded it , the voltage will still be going through the wiring you just wont be drawing amps with out the heater on , if the heater in the o2 is doing it you may have a bad o2 , it has a 1 year warranty exchange it

I have replaced about 3000 Bosch o2 sensors and have no more issues from them then the OE sensors which are also bosch made Ford branded

Tom
What makes you think Ford sensors are Bosch made? The ones I've bought were labeled "made in Japan", so they are more likely to be denso, or some other Japanese company.
09-07-2012 09:49 PM
s86chappy Thanks yall..
09-03-2012 01:01 PM
budawe Likewise with NGK sensors. Just try not to smack them on a parking curb. Part# A3B8B1, 22060. Half the price and visually identical to OEM.
09-02-2012 08:33 PM
1turbofocus I dont agree , I get ALL my o2 sensors from Advance or autozone , they also give a 1 year warranty and you dont have to ship it back to tously for the warranty , Ford also gives a 1 year warranty so I would ask tously if they offer that as well they should

If you think you have a short then replace the fuse WITH OUT the the o2 pludded it , the voltage will still be going through the wiring you just wont be drawing amps with out the heater on , if the heater in the o2 is doing it you may have a bad o2 , it has a 1 year warranty exchange it

I have replaced about 3000 Bosch o2 sensors and have no more issues from them then the OE sensors which are also bosch made Ford branded

Tom
09-02-2012 05:55 PM
andersonmh My experience is to go with OEM. I have had problems with Bosch. Make sure that you don't have a frayed wire that is shorting out. I'm assuming that this is the front O2. The rear is a problem if you hit a lot of holes and break the sensor.
09-01-2012 11:44 AM
s86chappy im throwing a PO141...replaced with oem and 1 denso.. still need to find out whats wrong cleaned the maf to..
09-01-2012 09:21 AM
jmoryl As pasta says, get the Ford sensor. A lot of people have problems using the Bosch sensors.
Quite inexpensive from Tousley Ford....
08-31-2012 11:18 AM
pasta dont know about blown fuses but fords do not like bosch sensors get them from tousleyford.com just did mine
08-31-2012 09:51 AM
2004svtfordfocus
O2 sensors new / check engine

i have bosch O2 sensors only maybe 8 months old on my svt and the light for check engine went on. one of the three codes was Bank #1 Sensor #1. Still had the problem, then found the blown fuse and the car was fine for one start. On the second start car would throw codes and the fuse would again be blown. I checked all of the wiring and connections and found nothing. the code appearing is P0133 and another one but i am to pissed to remember that p code #, please if i can have some help with this matter thank you


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:47 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.