Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Discussions > Ford Focus Builds & General Showroom > The TICK build thread

Ford Focus Builds & General Showroom Post pictures and information of your Focus being built or your car images here. We want to see your Focus! More Images: Visit Our Online Ford Focus Gallery

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: The TICK build thread Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-26-2016 11:03 AM
Magus2727 Well have a bunch of work to do. I have not had very good luck with bearings on my car this year. Accessory Tension Pulley went out as posted before. Got the new one from C-F-M.

My car was making another tapping noise and further inspection showed that the timing belt idler pulley also was bad. It was moving around on the bearing.

so YEA timing belt change. Only time I have done the timing belt on this car was when the motor was all the way out. I must say thats the easy way to do it.

Ordered the GATES blue comp belt. When compared to the OEM belt it looks like there is more reinforcement in the belt.



Using a new valve cover gasket. its from Magnum. They recently got bought by the same people who own Victor Reinz.



The edges do not seem as clean as the Feelpro, but the gasket has more of an edge. We will see how this valve cover gasket works out.

Also replacing the timing belt tension pulley Ford dealers here dont appear to stock these so ordered it on Thursday and getting it Monday. I guess they must not do to many timing belt changes on these cars or they are not replacing the pulleys while they do the work. My pulley was Concave...



I was able to get a 0.006" feeler gauge into the pulley. apparently its suppose to be convex and that helps the belt stay centered on the pulley? not sure if I have my concave vs convex correct. Either way new pulley.

The accessory idle pulley is still in good shape so will just be reusing that, we will so how long that one lasts.

During my prep work for the last NASA event I discovered that my AC was not working and completely dry. Working on taking off the connections and replacing a few of the gaskets. also going to put a new expansion valve, the one I took out looks a bit dirty.



Companies may a variable one for cooler climates (under 105*F) and for warmer (over 105*F) that is suppose to work better when at idle and lower engine speeds. Not sure I want to try them they cost about $14 more and some reviews have indicated that they are more likely to brake or not work.
03-17-2016 07:32 AM
Magus2727 Well likely going to be out there the 22-24th of April.
03-17-2016 05:43 AM
GodLovesUgly Wish I would have saw you were heading out to the track, I wanna go check out the car. I broke my hub on the svt at an autocross, snapped the same exact way.
03-15-2016 01:04 PM
Magus2727 Update:

Went racing this weekend and was able to complete some things before racing.

I started to have a ticking noise which I almost thought was valve train noise or my Alternator. Took the belt off and found out that it was the accessory idler pulley.



Was able to replace with a plastic GATES one while C-F-M shipped me out a new one with a new design having a press fit bearing.

Also did a full oil change and updated the Thermostat to a 180F.



Was able to get to a dyno and dial in my cams. Remember I am at 4,300 feet and also built for a Turbo but with no Turbo.



Got a final tune from Tom and fill up with 100 Octane at the pump. At $9.029 a gallon its amazing how fast the $ gauge goes.

I was able to lay down a 1.58.7 second lap on Utah Motorsports Campus (formally Miller Motorsports Park). Improved from averaging around 2.02 to 2.05 the first session to having 1.58.7 - 2.00 at the end of the last session.

YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.


All was not all smooth though.

Half way through my last session on the first day I started to hear some feathering when taking turns thought it was just my tires warming up. During a lap down on the Attitudes I had some massive brake fade. I came off that lap, (was also low on fuel) and filled up and looked at my front brakes. Saw that it looked my front caliper broke off and the caliper bracket was riding the rotor.

Well the Hub broke...











Had to get a new bearing and hub pressed in. New CV half shaft. New tie-rod end. Used my grinder to grind down the bracket and use a hand file to clean up the bracket. Also flushed the brake fluid. Got it fixed and ran 3 sessions. O'Reilly Auto Parts was able to pull through and with the help of a few connections was able to get me parts delivered and able to get back out on the track. Car was down for less than 18 hours.

Was able to hang out with another HPDE driver working towards Spec Z


#roadrashracing

Looking forward to another weekend of racing.

Edit: Ha funny thing just happened. The link that I wanted to use for a picture apparently did not pass the expletive filter on the site and was messing up the link from photobucket...
02-23-2016 11:11 PM
Magus2727 Ha, thanks. Some are not so shiny any more. It's been over two years since my car was back on the road and has seen daily driving. And with power steering leaks and oil leaks things are also coated I grime now again.

I am also consuming more oil than I use to, don't want to think about that. I don't want to replace rings again...

Thanks for the support.
02-23-2016 10:40 PM
prerunnerwannabe Ooh, there are so many fresh and shiny parts on your car Magus! Lookin good!
02-23-2016 10:11 PM
Magus2727 Cross over tube has been installed:



Ran the car for 10 min to warm up and hit pressure. No leaks were seen. Only spilled about 1.5 cups of coolant and was easy.

Not sure what to do with the little clamp that came with the pipe. Zip ties work well for most things, and I lost the hardware long ago that was used to attack the tube to the radiator support bracket.

There are pipe threads on one end that if I wanted a water temp I could put a sensor in. For the time being I have enough gauges.

Signed up for NASA HPDE 2 for March 11th and 12th. I am seeing some ware on the edge of the timing belt and hear a squeak I think coming from one of the pulleys so may have to do a timing belt change here soon.

I
02-21-2016 09:08 PM
Magus2727 Got a RAM Mount so I can put my phone in my car inside the windshield and use a track app to accurately get my lap-times.



Appears to be a good mount and holds my phone in nice and solid.

Update for some junk yard work that has been done...

My front seats both had the lever that allows for them to fold forward brake off and take the mounting post with it.



Went to the junk yard and got replacements for both sides so I now have my seats function. When installing I realized that there was aditional features from the 2003 ZX3 that I pulled the passanger side from. This allows the seat to also slide forward along with tilting forward.

went back to the junk yard and swaped out the lower track.





One on the right is the newer track that has an additional weld on bracket for a cable that connects to the lever. so now my seats can pull forward again on both sides and passenger slides forward!

Other update is getting an aluminum crossover tube.



I was not impressed by the lack of deburing and clean up. also the posts that come off the main tube were not ground flush.



but some work with a grinder bit and a dremmel fixed that. After cleaning up and bushing the outside I put a few coats of clear coat on the crossover from tarnishing and allow for easy clean up.



Next projects are to fix the passenger door handle, only closes when the door is locked and only opens from the inside. I have a door handle to swap out I got from the junk yard.

And then install the cross over tube. Tax returns will pay for an tune from Tom and either an OBD2 Bluetooth plug in or a Dual 160A GPS unit for the Harry's Laptimer.
01-12-2016 09:28 PM
Magus2727 Got things wired up today. I tied into the Green/Blue wire that is the 25 Amp fuse for the front windows. Its a switched power and accessible from inside the car.

Routed wires and installed the gauge in my open location in my custom pod.

It's alive!!!!



Got it wired up and working. So far the 1 min drive I took it seems to read good and at WOT it does not look like I am running lean which is good news . But does look like I am running way richer than I need to. Going to watch how it behaves as I drive into work tomorrow once I go closed loop and am warmed up...

I did put a bottle of fuel treatment in the tank so not sure how that will impact the A/F but cant think it would have to much of an impact on A/F.

Now to get a laptop so I can plug in the Xcal and the Analog input to data log with Tom.
01-12-2016 08:20 AM
SvviftSVT hmmm.. i used to know. but its been so long that i don't remember. sorry bud
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:59 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1