Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Third Generation > MK3 TSB, Recall & Problems Archive > Cruise control issue.

MK3 TSB, Recall & Problems Archive The place to chat about TSB and Known Issues for the 2012 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Cruise control issue. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-11-2014 07:32 AM
Cubedtothex
Quote:
Originally Posted by Island Tom View Post
Same issue with 2012 Focus Cruise Control

--------------------------------------------------------------------------------

Hi all, reopening an old thread. It looks like this is quite a common issue. I just called my local dealer as this has been an ongoing issue. It works intermittently, but lately it has been really bad. If I don't get it working after starting up, it won't work at all for the whole trip. I am scheduled to drive the car for a long trip in the middle of next month and I really need it working. Unfortunately the dealer wont take the car until 3 days before I go. I begged them to take it sooner to see what will inevitably need to be ordered, but they say they are booked solid. Rant over.

Questions: What is the likelihood of it being fixed on the first visit? Are there any bulletins that would improve their success? Should I try another dealer? Is this still covered under warranty? My car was purchased 4/2012 and is just over 27,000 miles.

Thanks!
You are covered until 36,000 or 4/2015, which ever happens sooner. Try another dealer, don't put up with their "we are booked solid" nonsense. If they were booked solid that far in advance, all the dealers would be booked because a major recall has occurred that makes vehicles undrivable with a stop sale.....which hasn't happened lately.
07-31-2014 09:43 AM
Island Tom Same issue with 2012 Focus Cruise Control

--------------------------------------------------------------------------------

Hi all, reopening an old thread. It looks like this is quite a common issue. I just called my local dealer as this has been an ongoing issue. It works intermittently, but lately it has been really bad. If I don't get it working after starting up, it won't work at all for the whole trip. I am scheduled to drive the car for a long trip in the middle of next month and I really need it working. Unfortunately the dealer wont take the car until 3 days before I go. I begged them to take it sooner to see what will inevitably need to be ordered, but they say they are booked solid. Rant over.

Questions: What is the likelihood of it being fixed on the first visit? Are there any bulletins that would improve their success? Should I try another dealer? Is this still covered under warranty? My car was purchased 4/2012 and is just over 27,000 miles.

Thanks!
06-20-2014 12:17 PM
Cubedtothex
Quote:
Originally Posted by JimTen View Post
Well I got the clockspring finally replaced about 2 months ago. It was working fine for a month and now is acting up again.

I am going to be setting up another appointment to have it fixed AGAIN!
Actually it was most likely the wiring harness. They told me that they had gone through 2 as they were repairing my car. My guess is that they broke a new one when installing it. I was beginning to have clock spring issues on my 2007 or at least that's what I was told. My airbag light was on so they greased some wire that had too much electrical resistance (cost me $93!).

I'm sure this is NOT something covered under the powertrain warranty. Usually just drive shaft, engine, and transmission.

The bumper to bumper warranty doesn't even cover fuses, which is ridiculous. My power outlet wasn't working so I replaced the fuse...but then it blew again. I hope I'm not having some sort of other electrical issue too...but then again, this was before my new wiring harness and clock spring. I haven't tried installing another fuse for my power outlets.
06-20-2014 11:42 AM
JimTen Yeah possibly. Either way, it's pretty shitty that the car isn't even 3 years old and I am having problems like this with it.
06-20-2014 11:30 AM
pablo94sc Well that's no a good sign if clock spring replacement didn't solve the issue. Maybe it's in your switch or the harness?
06-20-2014 10:26 AM
JimTen Well I got the clockspring finally replaced about 2 months ago. It was working fine for a month and now is acting up again.

I am going to be setting up another appointment to have it fixed AGAIN!
06-20-2014 10:21 AM
pablo94sc Add me to the list. 58k miles and it works when it wants to. Sometimes a good bang to the side of the steering wheel corrects the issue - even turning it on for me without having to hit ON.

Anyone know if the clock spring/cruise control is covered under the 60k mile powertrain warranty? I have no issue with replacing this myself if I let the SRS (airbag) capacitors drain overnight, but I'd prefer to let the dealer do it.
03-28-2014 09:22 AM
JimTen
Quote:
Originally Posted by FordService View Post
Thanks for updating us, amplifier28. Let me know how your appointment goes on Thursday; touch base with me via PM if you need any assistance.

Crystal
Hello Crystal. Are you still helping people out who are having this issue? I have been "dealing" with it for over a year now and I just want to get it fixed already. I am under an extended warranty. Please let me know.
12-16-2013 05:15 PM
Cubedtothex
Quote:
Originally Posted by amplifier28 View Post
Are your cruise control still working after clock spring replacement?
Yes, so far so good.
12-12-2013 09:35 PM
amplifier28 Are your cruise control still working after clock spring replacement?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.