Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Something's wrong with my Cruise Control...

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Something's wrong with my Cruise Control... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-16-2014 04:00 PM
tmarc75 Sorry to bump an old thread but I did the diagnostic and got the zero flashes. So suspect circuitry or steering wheel controls. How can the wheel controls be an issue if in doing the self test all are pressed and the self test works? So suspect cicuitry. What needs replaced? Any input from anyone?
04-22-2013 01:46 PM
bringler26 Check your tail lights make sure none are burnt out. Including the high mount.(third brakelight)
04-22-2013 01:43 PM
hmagayle
cc doesn't work and no cc light

cc doesn't work, I check all fuses and replaced two. First of all the cc light on dash doesn't lite and when I replaced fuses it still doesn't lite. when starting or in start position before engine starts no light for the cc. any ideas
02-08-2012 12:08 PM
jay-rod05
Quote:
Originally Posted by mccreet View Post
yeah thanks, i tried the diagnostic test and it came back 3 flashes, which means brake switch curcuit, my mechanic is gonna handle it from there. i got 3 servos at the junkyard for each one like $15. i will let u know how it turns out in a few days.
The brake switch circuit should be an easy fix. Go back to the junk yard and pull a stop lamp switch and brake pedal position switch:



02-06-2012 06:00 PM
mccreet yeah thanks, i tried the diagnostic test and it came back 3 flashes, which means brake switch curcuit, my mechanic is gonna handle it from there. i got 3 servos at the junkyard for each one like $15. i will let u know how it turns out in a few days.
02-06-2012 04:26 PM
6SPD_soul Those servos can be fixed. My moms 05 ZX3 has a dealership installed cruise control, and awhile ago the cruise stopped working. I had dealt with cruise control problems in the past so I knew what was involved, and after finding no problems elsewhere I looked at the servo and shook it and could feel/hear parts loose inside the servo box. Took it apart and found that some screws had come loose from the plastic gear mechanism. Fixed it easily and it works like a champ now. The one in her car uses an electromagnet to pull on its throttle cable and the servo was actually mounted on top of the engine on a rail, I know factory installed are not as accessible as that.

Mccreet, you have any luck with that self diagnostic procedure?
02-06-2012 02:54 PM
spiller CC Servo $480 or the junk yard...
Yea, hope for a switch or cable issue.
02-03-2012 10:47 PM
mccreet I ve replaced steering wheel switch,servo 3 times, checked fuses, and brake lights and i hope this procedure somebody posted will save me.
12-18-2011 06:54 AM
alz focus Give this a shot. I copied it from another post. It was how I figured out my cc problems.

The test is basically this: you're going to be turning the ignition key on and off repeatedly and then hitting the cruise control buttons quickly in a specific sequence, and then the cruise control light will blink repeatedly, and the number of blinks tells you where the fault is. It's easy to do once you get it sorted in your head and you won't mess anything up if you don't get it right the first time.

If it's a manual, don't depress the clutch. If it's an automatic leave it in park. First, turn the ignition to the accessory/run position but don't start it. Press and hold the CC off switch and then repeatedly turn the ignition from run to off and back to run again, you should do this 3 or 4 times. End this sequence with the ignition in the run position and then let go of the off switch, and you should see your CC light blink once, which means it's ready to run the self diagnostic. If it flashes 5 times at this point then it's a faulty speed control module, which is that servo I mentioned above. Quickly after the light blinks (like a second after), you then need to hit the other cruise control buttons in this order, and you will need to hit them fairly quickly for the test to proceed:

1. On
2. Resume
3. Coast
4. Set/accel

The CC light should blink once after each button you hit. Kind of take your time hitting the buttons and it's easier to keep track of the flashes, which is important at the end because you need to count the number of flashes that come after you hit "set". There won't be an immediate flash after you hit "set", there will be a slight delay, and then will come another short series of flashes. This next part is all verbatim (except for the parenthesis) from the Ford guide I'm translating here.

0 Flashes (no flash after last button is pushed): suspect circuitry or speed control steering wheel switches.
1 Flash: Static test passed (cruise control should work)
2 Flashes: BPP (brake pedal position) switch is damaged, circuit is damaged, or the brake or clutch pedal was applied during test.
3 Flashes: Brake deactivation switch is open or circuit is damaged.
4 Flashes: Indicates the speed signal circuit is open or damaged (wheel speed sensors, ETC)
5 Flashes: Suspect circuitry or module.
12-18-2011 01:54 AM
69Hcode It it a manual? On my SVT the cruise control switch at the clutch pedal has come out a couple times.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:48 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat