Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > Battery Corrosion 2010 SE

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Battery Corrosion 2010 SE Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-05-2012 07:26 PM
ranger97 In my vehicle I would like to remove the battery tray to inspect underneath. But I think the bolts holding it down are actually studs attached to the metal plate underneath. These are so corroded they will probably break by removing.

Does anyone know if the metal plate supporting the box can be replaced? It looks like there may be something underneath the plate that is supported by it. I have the manual transmission, which is directly below the battery and support.

The dealer (non-ford) that sold me the vehicle wouldn't remove this to inspect underneath, and Ford Customer service told me there is no technical support that can tell me anything about it, I have to go to the dealer and pay an $80 fee for them to even talk to me.
12-04-2012 07:41 PM
nekoashide When that started to happen I replaced the battery. Texas heat got to it and I knew it was only a matter of time before it started eating things.
12-04-2012 07:38 PM
goinloco1 what I'm seeing is pure lack of under hood maintenance from the pictures I'm seeing. Keeping the engine compartment at least half way clean prevents alot of problems.
Dirt attracts moisture which in turn will give voltage a path to flow. This includes across the top of the battery from terminal to terminal or terminal to hold down, or any path it can establish for that matter. the corrosion your seeing is actually created by small amounts of sulfuric acid (yes, they give off vapor occasionally. when this mixes with moisture it becomes acid again) from the battery mixing with the moisture in the dirt and being attracted to a voltage source.
the powder you are seeing is actually dried acid and is in itself caustic. don't brush it off and blow it away, you're just leaving it to create corrosion elsewhere later, or find it's way back to where it started.
either mix up some baking soda and water or grab a can of coke, either will neutralize sulphuric acid. gently pour on and you'll see it foam (I pour it over the entire battery and terminals and also the top of the tranny). let it do its thing for a bit, apply liberally once again and give a little time, when foaming quits rinse with fresh water and brush, or disassemble then reapply once more, then rinse and clean.
Keep your battery and surrounding area clean if you want it to keep you happy. as some have found, repairing battery cables isn;t cheap. but 20 minutes every 6 months or so can save a boatload of time and money. :)
12-04-2012 09:43 AM
mjd4277 It hasn't happened to me yet,and I live in a state where you have to watch out for salt corrosion.
12-04-2012 01:06 AM
ranger97 I just purchased a used 2011 Focus. There was a small amount of corrosion on the hold down. I thought this might not be unusual but upon removing and cleaning, noticed corrosion down in the battery tray and on the support plate and even underneath that, I fear on top of the transmission. There were pools of acid in the depressions where the tray bolts are. I cleaned the tray up however the bolts are so corroded I think they will break if I try to remove them. Going back to the dealer. Has anyone else had this experience?
12-21-2011 09:56 AM
rambleon84
Quote:
Originally Posted by BillyKeith View Post
2010 Ford Focus SE sedan, 4 cylinder. Seeing white corrosion around battery "hold down" but none on either terminal. Could battery be bad or beginning to fail?
not sure about your battery location/hold down but the same thing was happening with mine. I'm going to assume its the same thing I'm talking about.

I painted the bare metal hold down with some high temp black paint i had laying around. I took it off, cleaned off the corrosion and then painted it with a couple coats. Let it dry and then reinstalled it. I bet some of the liquid plasti-dip would work well for this hook too, just dip it and let it dry.

Mine was corroding right at the hook where it was anchored to the plastic (right above where the FSWerks sticker is on my CAI on this picture.)


I'm not sure why it was corroding there as it actually isnt touch the battery, so not sure if it was just the metal the hold down was made out of? I hit up the nut that screws the hook/hold down too but the paint wore off as soon as i reattached it
I havent noticed it corroding again yet, i painted it this past spring.
12-21-2011 04:22 AM
TheGlassMaker I know you said it's on the tie down and not the terminals but I'd give it a this a shot to see if it goes away. Here's how I cleaned mine up and the products I used I got at autozone (not pictured I used bulb grease on terminals before attaching everything).

Quote:
Originally Posted by ranger_mclaren View Post

Cleaner, protectant, and washers.



What I have been dealing with.




I sprayed cleaned off and wire brushed the terminals, and the connectors. It looks like the factory connectors are cooper too.



I cleaned up all the over splash and greased up everything and reattached all the wires then spaid on the protectant.
12-20-2011 04:07 PM
iminhell It's normal for a lead/acid battery to 'leak' around the terminals. This is one large advantage of dry or gel batteries, no corrosion/leakage.
The other thing is if the cable ends are not lead there will be "galvanic corrosion" taking place, on top of the leaking battery acid. I'm not sure what type of metal Ford used for the cable ends.


But you're best bet is to remove the cables, clean them with a wire brush, baking soda and warm water. Then use wheel bearing grease or dielectric grease to coat the terminals and cable ends. This seals out air and prevents corrosion.
12-20-2011 11:05 AM
BillyKeith
Battery Corrosion 2010 SE

2010 Ford Focus SE sedan, 4 cylinder. Seeing white corrosion around battery "hold down" but none on either terminal. Could battery be bad or beginning to fail?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:31 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.