Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus First Generation > DURATEC Performance (2003-2007) > So I blew up my Duratec 2.0L time for new engine.

DURATEC Performance (2003-2007) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: So I blew up my Duratec 2.0L time for new engine. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-06-2012 03:06 PM
streetfocus I wish someone would make a stickied thread or how -to write up for the swap. It's the unknown factors that scare most away from doing this swap. Good to know that if you keep your D20 IM then you can use your wiring harness, accessories, and ecu/pcm.
12-05-2012 06:40 PM
SYZ jeez, please people, don't go running your motor without the proper tune in there first.

The mtx75 will bolt up to the 2.3 or 2.0 just fine. I believe the same goes with the ATX. I did the 2.3 swap awhile ago and it was pretty straightforward.
12-05-2012 05:51 PM
RedRiderr13 subscibed, this will be of much help. did the 2.3 bolt up to the 2.0 trans fine?? sorry if waking a dead thread
11-11-2011 12:41 PM
GoodwrenchEG got the tune in, Seems to shift lateer then I want on WOT, I will get a better tune later, also my CEL light is on. NOt sure how t data log or anything yet..
11-10-2011 02:32 PM
GoodwrenchEG new motor is in the works, I need to get with ryan and you and get something for the first week of Febuary. cannot do much till then, for now it runs, but like you said, making noise. Still needs tune reguardless. and I will be ready for new motor. Since tune was paid for before the other issues might as well get it done.
11-10-2011 01:24 PM
Buickboy
Quote:
Originally Posted by 1turbofocus View Post
The duratec like the Zetec and SVT has the PCV going to the intake as well as the valve cover breather , this puddles oil in the intake manifold , I have seen as much as 2 inches of oil in intake manifolds

Have you looked there ?

Did you get your flasher , I am sorry for the delay I am on day 7 with my Wife in the Hospital

Tom
Yeah PCV is the devil on a modded engine!

Best of luck to your wife Tom, hope everything turns out ok.
11-10-2011 01:02 PM
st12131 Dont you first need to get a new motor?
I know when we looked at it, it was making a lot of valve train noise! (And I mean a lot!!!)
I would first get a good motor in there that might not have any issues to fix then worry about the other stuff!

Bob
11-10-2011 12:36 PM
GoodwrenchEG got the flasher , just sent the email with programing specs.
I will have to look into the PVC valve issue
11-10-2011 09:31 AM
1turbofocus The duratec like the Zetec and SVT has the PCV going to the intake as well as the valve cover breather , this puddles oil in the intake manifold , I have seen as much as 2 inches of oil in intake manifolds

Have you looked there ?

Did you get your flasher , I am sorry for the delay I am on day 7 with my Wife in the Hospital

Tom
11-10-2011 04:00 AM
GoodwrenchEG WHat does it mean when you drive at 70ish and then get a puff of smoke ( oil burn ) then a plug fouls then after 1 minute it clears up on expressway?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:34 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.