Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Regional Forums > Great Lakes Fanatics > Michigan people

Great Lakes Fanatics Serving the Illinois, Indiana, Michigan, Minnesota, Ohio and Wisconsin regions.

Search This Forum | Image Search | Advanced Search    
FocusFanatics Merchandise

Thread: Michigan people Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 11:33 AM
Aku
Quote:
Originally Posted by svt1391 View Post
That's weird. I didn't notice a single issue when I drove it. Crazy how quick it popped up
my only assumption is that some douche canoe effed with my tires. I noticed when I went to fill up the tire the first time that all my valve stem caps were missing. So I want to say someone manually deflated the tire and I didn't notice at 30-35mph street driving but when I got up to 70-75 it became prevalent..
Yesterday 11:01 AM
FocusedOnSVT New to the SVT, had that wagon before this.
Yesterday 11:00 AM
svt1391 That's weird. I didn't notice a single issue when I drove it. Crazy how quick it popped up
Yesterday 10:34 AM
Aku
Quote:
Originally Posted by wordyahurdd View Post
Did you buy those new?
Yup. Bought the blizzaks new for the R32. They went on damn near Christmas in December and came off at the end of April '14. And then they went back on the Audi mid to late Nov.
Yesterday 09:50 AM
wordyahurdd
Quote:
Originally Posted by Aku View Post
Dunno. But after I looked at the tire in the light after work... it's clear the tire is jacked. The entirety of the sidewall is wavy as shit. The treads look fine but the sidewall is for sure jacked. Belle tire just called to confirm that. Sounds like my tires aren't' worn enough to warrant ordering a new tire specially shaved down so they can have a tire installed for me for decently cheap. Sounds like it would be less than the price of a shaved tire shipped from Belle tire.

Did you buy those new?

Quote:
Originally Posted by FocusedOnSVT View Post
Getting the SVT either this weekend or early next week

New Svt owner? Welcome
Yesterday 09:03 AM
FocusedOnSVT Getting the SVT either this weekend or early next week
Yesterday 08:31 AM
Aku
Quote:
Originally Posted by wordyahurdd View Post
That don't sound good achoo...maybe rim isn't on tire beads?
Dunno. But after I looked at the tire in the light after work... it's clear the tire is jacked. The entirety of the sidewall is wavy as shit. The treads look fine but the sidewall is for sure jacked. Belle tire just called to confirm that. Sounds like my tires aren't' worn enough to warrant ordering a new tire specially shaved down so they can have a tire installed for me for decently cheap. Sounds like it would be less than the price of a shaved tire shipped from Belle tire.
Yesterday 08:19 AM
TheBrain88 Ugh....so no ST yesterday, they got the wrong airbag sensor so I gotta wait till today or tomorrow for it to be fixed

Also...kinda want a tesla now...

YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.
01-26-2015 11:21 AM
wordyahurdd That don't sound good achoo...maybe rim isn't on tire beads?

How the hell does my phone work wayyyy better with LTE turned off and only using 3G
01-26-2015 08:22 AM
Aku Ugh. Car trouble this AM. Minor but annoying. Heading back from kzoo get on the highway and suddenly the car is shaking pretty bad like a wheel weight fell off and it's pulling hard to the left. Get off at the next exit and check air. Front left was extra flat. Filled up to 30psi and drove 20 miles. was down to 25psi. Got back on the highway and drove another 60ish miles and checked again. About 24psi but still pulling hard left. Checked the air in all tires and set them all to 30psi and kept going. Still feels like a wheel weight fell off somewhere and still pulls left. I have to hold the wheel slightly right for it to track straight.

Guess I need to head to the local belle tire either at lunch or on my way home and have the front left wheel/tire looked at and probably also an alignment done. Yay
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:24 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat