Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004) > HOW TO: IMRC Removal and Repair

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest

Thread: HOW TO: IMRC Removal and Repair Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2017 07:34 PM
Tarmac Bump, because I bet I'm the most recent person to fix this and I wanted to add my thoughts to the definitive IMRC megathread.

I replaced everything with new parts rather than try to mess with soldering. I ordered a new IMRC from Tousley and the CFM billet DSI lever.

It took a little longer than I expected, but probably because I cleaned up a lot of leaky battery gunk and got a new battery. I would say it's a 2-3 hour job if you are really careful, maybe 1 hour if you are an IMRC mastah.

I didn't realize this until I started working on it, but my car has had the cable completely disconnected from the DSI ever since I have owned it. I didn't suspect anything until I started getting the rattlecan sound, my mechanic unplugged the IMRC to stop the godawful sound, and then I got the code (need to pass smog).

Some thoughts: putting on the billet DSI lever is pretty scary. I can see how you might deform it by jamming it on in the wrong position. I used a dab of vaseline inside and a small jeweler's mallet to tap-tap-tap.

Mounting the cable housing to the little notch holder thing: you should connect the DSI lever to the cable terminal first. Then pull the cable all the way back with your hand (DSI in high RPM position), put the bare wire into the notch, and let the housing click into place on it's own as the DSI returns to rest position.

Cable routing: since the previous owner detached the entire cable, I'm not sure I have the optimal routing path. At least I know I used the correct hole in the subframe.

Battery acid: Not totally sure if it was related, but I can see how battery acid could ruin your IMRC or cable, it is right underneath. If your battery leaks, replace it.

MPG and performance: I better get at least 2-3 MPG better on my next tank. I always wondered why the hell I got 23MPG all day. We'll see

Cruise Control: I don't recall anyone mentioning cruise control in any IMRC thread - but mine has been inactive ever since the IMRC plug was pulled. When I fixed it, the CC came back. Yay.
01-11-2017 07:25 AM
PabloFord Thanks, AMAWDS for your reply.
01-08-2017 04:20 PM
amawds So your IMRC is mechanically functioning correctly. You need to pull it apart and clean the contact inside. It's pulling the cable, but the contact is corroded so the engine computer can't see that it successfully did its job so it fails the self test and cuts power to the IMRC. Ironically the thing that's supposed to show whether the device is functioning or not is the thing that fails in it the most. However, that isn't the cause of any of your symptoms. The car will start and run just fine without the IMRC in working order.
01-08-2017 01:30 PM
PabloFord I'm a new SVT owner / driver and newby to this site. Purchased my '02 needing some work. Has an IMRC issue but after reading this entire thread I don't see anyone with the same. I do have the P1518 code but here are my symptoms: 1) constant shhh...shhh...shhh from the IMRC. 2) Slow to start when weather is cold, and must push throttle down or it will not start, and 3) Poor mpg - 24 in country and highway driving. IMRC is pulling the cable and immediately releasing it; repeat. Any thoughts?
09-16-2016 05:28 PM
Sniper Focus Sometimes I want to make another thread. first post is helpful, but not the best method. Then there's other good info buried in the 17 pages.
http://www.focusfanatics.com/forum/8731209-post143.html

Remove all screws except for the two that hold the connector to the board. Dig the epoxy out from around the connector. I sealed it back up with RTV which is easier to remove for next time. I have to clean my IMRC about every two years.
09-15-2016 08:31 PM
Billfromnj05
Quote:
Originally Posted by Sniper Focus View Post
Quote:
Originally Posted by Billfromnj05 View Post
I just ordered a new one of these from summit racing.

https://m.summitracing.com/parts/rnb-911-928 Dorman 911-928 intake manifold runner control. Site said it was for 04 focus svt which I have obviously lol. But when I got it today the cable on it looks really short like I don't think it's gonna reach at all. Is there anyway to change the cables? Did anyone else get one of these and did it fit? I mean if it works since cable is so short looks like I would have to relocate the actually module to engine bay doe where close. I don't know
Didn't know Dorman made these... they say it's for a 96-07 Taurus. Cant trust Summit 100% if its not a SBF or a SBC.

You can open it and swap the cable, the board has to come out though. You can do it the easy way like me and use the non de-soldering method.
How did u do it without de soldering? U did the how to? Or you swapped the cable? Please let me know
09-15-2016 08:11 PM
Sniper Focus
Quote:
Originally Posted by Billfromnj05 View Post
I just ordered a new one of these from summit racing.

https://m.summitracing.com/parts/rnb-911-928 Dorman 911-928 intake manifold runner control. Site said it was for 04 focus svt which I have obviously lol. But when I got it today the cable on it looks really short like I don't think it's gonna reach at all. Is there anyway to change the cables? Did anyone else get one of these and did it fit? I mean if it works since cable is so short looks like I would have to relocate the actually module to engine bay doe where close. I don't know
Didn't know Dorman made these... they say it's for a 96-07 Taurus. Cant trust Summit 100% if its not a SBF or a SBC.

You can open it and swap the cable, the board has to come out though. You can do it the easy way like me and use the non de-soldering method.
09-15-2016 06:56 PM
Billfromnj05 I just ordered a new one of these from summit racing.

https://m.summitracing.com/parts/rnb-911-928 Dorman 911-928 intake manifold runner control. Site said it was for 04 focus svt which I have obviously lol. But when I got it today the cable on it looks really short like I don't think it's gonna reach at all. Is there anyway to change the cables? Did anyone else get one of these and did it fit? I mean if it works since cable is so short looks like I would have to relocate the actually module to engine bay doe where close. I don't know
09-10-2016 09:27 PM
pasta This is part of if not all your issue.
09-10-2016 06:11 PM
Billfromnj05 Quick question. I have cel on and it says intake manifold control stuck open code. So I'm guessing it has to do with the irmc module. When car idles it runs like crap spitter and sounds like it want ms to stall. And in low rpms when I go from a stop the car bucks like its gonna fall on its face and has no power. Is this behavior all from this box? So I have to do this how-to to fix it and it will get car back to normal?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:03 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1