Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Discussions > Official Polls & Surveys > What sorts of problems has your Focus experienced?

Official Polls & Surveys Please take a moment and participate in our online polls and surveys.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: What sorts of problems has your Focus experienced? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-23-2014 05:49 PM
coldbear
((((((check your grounds)))))

Try cleaning all your grounds. These dyno's will make the voltage but it (volts) has to have a clean route back to the battery. Also take your generator to a private rebuilder and have him put the heavy diodes in the case. Many parts houses buy the gens. by the thousands and get better prices with the manufacturer installing junk leaking diodes. I went through the same thing until I found a solid rebuilder. Makes a great difference especially in winter and summer months. Good luck.
09-23-2014 10:24 AM
ComradeChaos Alternator - replacing the 6th one since buying it brand new in 2003.
You realize what a PITA it is to change out an alternator???

I replaced the battery harness last weekend and the thing was sending 14.7 VDC no problem. Two days later it shit the bed and is only sending out 12.5 VDC (meaning nothing).
I'm going to change the pigtail connector - I just wish I could replace the whole thing cable from the ECU to the alternator. I'll cut out the fusible link (if there is one), maybe that is what is KO'ed. The first alternator lasted 7 years, then the next one was 1 year, then the next one was 3 years then the next one was 5 weeks and now this last one has been in / running for less than 2 weeks.

Will I ever buy another Ford....I doubt it.
09-15-2014 11:27 PM
Super 7 I've only put a fw thousand miles on it. I put in a water pump, timing belt, and both tensioners, but that was only to avoid a problem. Its an old car, and its going to sit a lot, so brakes might give trouble. I need to flush the fluid. That helps a lot.
09-15-2014 08:44 PM
02Wagon5spd Ignition coil and master cylinder over 12k miles in a year and a half.
09-15-2014 06:12 PM
mikebontoft Should have bought BMW. Geez
09-15-2014 06:10 PM
carol3162
Quote:
Originally Posted by markhamgurl View Post
I'm interested to find out what percentage of members here have had problems with their Focus. It seems like all I read are stories of these vehicles breaking down and being really unreliable!

I think we all tend to focus on the negative rather than the positive, so I thought a poll might give a better idea as to what sorts of issues people are having.
Mine stops accelerating while driving, court date in a couple of weeks, dealership won't even look at my care, another dealership found problem...yesh, should have bought Subaru!
08-21-2014 08:13 PM
ryanbk400 101k, Put over 50k in it in 2 years. Aside from doors not wanting to unlock at random times, I haven't had any trouble.
08-20-2014 01:54 PM
sleddingguy 90k no problems other than normal wear and tear.
08-18-2014 01:32 PM
Mr Orange SVT
Quote:
Originally Posted by dave89iroc View Post
You've never heard or experienced clutch chatter?
Same here. I don't drag race but I've got 134k on an original clutch and its never made any strange noises. I know what chatter and shutter are in a drivetrain because I used to get it sometimes in my Bronco but the SVT has shown none of that.
08-18-2014 10:07 AM
ComradeChaos I can't participate with the poll due to my current frustration level.
2003 Focus ZTW
Bought it brand new.
Factory alternator went out in 2010.
Replaced it in 2010 (+battery) and THAT alternator went out in 2011
Replaced THAT alternator (+battery) in July 9, 2013.
Just replaced THAT alternator last night.

WhyTF does this thing keep eating alternators??
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:55 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.