Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Fuses

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Fuses Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-11-2004 10:23 AM
S2
Quote:
Originally posted by Epox
Thanks for all the help but i fixed it. there was a small nick in the remote wire for my amp that was arcing against the body and blowing the fuse. i fiked it and it works great now.
That is what I thought it might be.... glad you figured it out....!
08-11-2004 08:36 AM
CKA I had the same problem, I had 2 buy a bunch of fuses from Napa, they were the only one's who had them here, but the problem dissappeared, it was weird.
08-11-2004 12:07 AM
Epox Thanks for all the help but i fixed it. there was a small nick in the remote wire for my amp that was arcing against the body and blowing the fuse. i fiked it and it works great now.
08-10-2004 11:59 PM
dudemanzx3 Did you unhook your system and try to start it then? If you did and the fuse still blows, I would take out the whole system before I took it in to the dealer. They'll do almost anything to try and blame you for the gripe so they don't lose $.
08-10-2004 09:09 PM
downloader take it back to the guy who installed your sound system

www.bluewhippet.net
08-10-2004 08:35 PM
Epox Well i tore everything apart its nothing to do with my stereo (stock HU wired to an amp) The fuse that keeps blowing is #41 it has something to do with the cluster when the car first starts cus it takes about 60 sec for the gauges to read anything. when i first blew the fuse i replaced it and it workest for about 2 min before it went again, but now it goes every time i turn the key. what im woried about is if i take it to the dealership they will say that the instalation of the amp voided my warenty.
08-10-2004 07:56 PM
S2 Do you have an aftermarket stereo? Chances are that you are shorting out somewhere causing the fuse to blow. Check the wiring or the HU and the remote wire for the amps, etc. Maybe the rubber around the wire had gotten worn off at a sharp angle where the wire is run. Something to check anyway..... I used to be hardcore into stereos and I had so many fuses blow when I started out it was insane.

Anyway, check it out..... you might also want to ask SA_PYRO_NE who is the moderator for the car stereo 'ICE' section of this board and see if he has any ideas.....

I doubt it has anything to do with your gauge cluster, your car is a 2004. If it's not any of your stereo wires, then take it to the dealership, you have warranty, use it.
08-10-2004 05:40 PM
Epox
Fuses

For some reason the 7.5 amp fuse that controls the gauge cluster and the remote turn on wire for the radio and amps blows when i turn my key to start my engine. I dont think that it is my stereo b/c ive had it in there sence the 2nd day ive had my car ive had it for 2 months now and it just started doing this today Please help

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:48 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat