Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > SVT stalling and cleaning your ground connections

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: SVT stalling and cleaning your ground connections Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-18-2012 06:15 AM
whynotthinkwhynot The last post in this thread (before yours) was 3 years ago. Hint: Look in the dark blue banner above the avatar. You're probably not going to get an answer. I highly suggest you ask the question in the SVT Performance Forum instead since you have an SVT.
11-18-2012 02:20 AM
Aaron1331 mine stalled 3 times within 3km. always in gear.
4th gear slowing into a corner
neutral at a stop sign and
3rd into my street.

what gauge wire am I using for the wire upgrade?
10-11-2008 02:20 AM
boarder Alright cool. Cause i think that mine is starting to act up. It was surging the other day but only for a few moments and i didnt think about what it could be. I thought gas or intake. but its prolly that! Post back up here and let me know how it goes. I will prolly have to do it soon and a great write up would be sweet! hahah
10-10-2008 09:07 PM
DirtyDeeds ^^I did all that and it didn't make a difference. The IAC is brand new. The car drove better, but it kept on stalling.

UPDATE: My first impressions after adding the big 3 ground wires are that it has made quite a difference. The car started easier, the idle is smoother, there is little or no surging, the car wants to rev more freely, the flicker in the dash board lights is gone and it hasn't come close to stalling!!!

I'll keep an eye on it and report back over the next few weeks.
10-10-2008 08:04 PM
All Black SVT i had this problem but it was due to my o2 sensors being on for a month. (upstream and downstream) but when i replaced them, the guy who checked the codes told me to also clean the throttle body, MAF, and also the Idle control by taking out and spraying it down with carb cleaner. which is that part under the throttle body. its about 4 inches long and about 2 inches thick, has two bolts holding it in, one which is visible under the throttle body and on that is a little hard to get to. just my $.02.
10-10-2008 05:18 PM
DirtyDeeds JRODSVT said that he did and that it helped. I got the cables made this afternoon and I'll put them on in the morning.

EDIT: I just installed the big three ground cables. I'll let you know how it turns out.
10-10-2008 03:49 PM
boarder I get light dim and when the stereo is on in my car it sometimes dims the lights a little. Has anyone done the Big 3 on their car to stop the stalling yet?
10-10-2008 12:25 PM
DirtyDeeds ^^You might be onto something there. I'll look into it. I seem to remember a thread or two around here covering this very subject.

Thanks!

EDIT: Here's a link to a great post with pics on the big three grounds...
http://www.focuscanada.net/forum/ind...showtopic=8122
10-10-2008 10:44 AM
JRODSVT Have you considered the Big 3 upgrade?

engine to chassis ground, battery to chassis ground, alternator to battery positive?

I did this a while ago and it helped my stalling problem. even with having an alternator that does not turn on until 1200 rpm.
10-10-2008 09:31 AM
DirtyDeeds I forgot to add that one. I had an MSD coil pack when the problem started and swapped back to the stock coil pack when I changed out the plug wires. It made no difference.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:33 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat