Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Thermostat housing, How-to, but need detail.

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Thermostat housing, How-to, but need detail. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-14-2012 10:29 PM
amc49 No vacuuming needed, make sure small hole in stat faces straight up to match the small hose entry in the front cover. The system pretty much bleeds itslef and quick then.

On Focus cars BOTH fans come on as one, they are both on low or both on high as needed.

The stat goes in with the smaller disc end toward back of car. Again, small hole in outer edge faces straight up. That hole may have a loose BB or little poppet trapped in it, I always take it out on mine. That stops it from getting stuck from corrosion later in life.
11-14-2012 04:36 PM
Xin Ansin I watched a video on replacing the thermostat housing, the guy vacuumed all the air out of the coolant system as he refilled the coolant. is it strictly necessary to do so? or can I just fill it up and let the system to it on it's own?
10-03-2008 03:24 PM
Executionerhk the OEM ford part...
the parts department gave me a wrong part...
that is why it won't fit...
and i believe my friend mount the themostat wrong direction..
which should be the reason why it is over heating...
10-01-2008 04:01 PM
hEaT Both of my fans come on with temp...

Just checked a few min ago. I have an SCT tune so that may change it.
10-01-2008 12:21 PM
PlasticRacer i really don't mean to jack this thread, but i'm glad i looked at it cause now i can get a lil more specific as to what i'm looking for. That hose that comes from the firewall and goes to the thermostat, the hose in between that attaches to the hose coming from the firewall, #18472, what is that hose called because i need to replace it on my car? thanx
10-01-2008 11:52 AM
hEaT Have you replaced the thermostat yet?

If you do, the OEM Ford one should be fine. No need for a cool one unless you want to seriously track the car.

You can test your current one this way:
http://www.focushacks.com/index.php?modid=60

I'll have to pop my hood and look, I'm not sure how the fans work. One may be the A/C fan and the other a two speed, or one is low speed and one is high speed. I'm not quite sure, but I'm guessing the first. If it is the first, it sounds like your resistor pack is shot.
09-30-2008 12:04 AM
Executionerhk bump for the question...
i want it to be fix, please help
09-29-2008 12:17 PM
Executionerhk ok hEaT,

I have driven to school and make the engine hot enough to make the fan turn on.. and I max out my A/C, seems the fan on the drive side is blowing hard... dono about the pessenger side yet... coz i am late for class... so i cannot check it.... and it was not even a mile drive... my car heat up completely... i seriously think my new themostat is not working...

guys more idea please

best regards guys,

Steven
09-29-2008 11:46 AM
Executionerhk hEaT,
I will try to make it over heat, and then check the fan...

but i still think it is the new thermostat, because it was an open item... should I go with the ford oem one from the dealership?

thanks,
Steven
09-29-2008 11:29 AM
hEaT
Quote:
Originally Posted by iminhell View Post
Well, do the fans come on?
If not there is your problem, with the solution probably being a new Cooling Fan Resistor Pack.
The fan should come on when you turn the A/C on as well. If not, that's your problem.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:15 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat