Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > spring noise from front suspension after coil change

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: spring noise from front suspension after coil change Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-12-2008 08:37 PM
zx505focus
Quote:
Originally Posted by jetrinka View Post
The cup that retains the top of the spring just as the cup below the spring retains it. It fits between the spring and the upper bearing mount located just under the top of the shock tower.
yes, thats what im talking about, thanks
05-12-2008 08:32 PM
ken6x6 yup ... that looks good to me.
05-12-2008 08:10 PM
siffleu what do you think of that ?
http://img99.imageshack.us/my.php?im...oto0019vd6.jpg
05-12-2008 08:04 PM
ken6x6 make sure the spring is set in to the bottom cup correctly, there is a certain way the spring has to sit. the bottom cup looks like the bottom of the spring and it fits rite in.

i didnt have mine it right and i kept making a "twang" noise. all i did was jack up the front end and spun the spring till it popped in place.
05-12-2008 07:04 PM
siffleu
Quote:
Originally Posted by jetrinka View Post
Check the swaybar endlinks to see if they are tight.

I've done all of the above

the rubber on the swaybar endlink are worn on both side

is this can cause the "squeee squee rust spring like sound"

the sound can be hear by just adding weight into the car so I did the test with a helper and put my hand on the endlink and I was able to feel the vibration of the sound into the endlink

is worn, cracked rubbers of endlink can cause this annoying noise ?
05-06-2008 09:05 PM
jetrinka The cup that retains the top of the spring just as the cup below the spring retains it. It fits between the spring and the upper bearing mount located just under the top of the shock tower.
05-06-2008 09:02 PM
siffleu upper cup ?
05-06-2008 08:34 PM
zx505focus this happen to me when i put my svt suspension on, all it was, was the upper cup was upside down. check that out.
05-06-2008 08:14 PM
jetrinka Check the swaybar endlinks to see if they are tight.

Also check the main nut that retains the piston in the strut on the top of the strut tower. The big one in the middle of the three small ones. If it is not tightened down all the way it will allow the spring to shift around when going over bumps and such making a noise.
05-06-2008 05:35 PM
siffleu
spring noise from front suspension after coil change

Hi there,
I own a 02 sedan, with SPI engine, 80 000km, had the coil problem, (both were broken) and about a month and half later, I have "spring" noise when I turn the steering wheel and when the suspension traver up and noise

doesn't seem to come from the top plate, it sound more like a "spring" noise "squi squi squi" when the suspension is working from up to down, and a noise that sound like a old house door that make noise when I turn the steering wheel...

the noise seem to come from both side...

anyone have an explication ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:51 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.