Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > MK1 Interior Mods & Upgrades > How-To: SVT e-brake install

MK1 Interior Mods & Upgrades The place to chat about performance gauges, shifter knobs, custom interior paint, car seats or any interior upgrades for the 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: How-To: SVT e-brake install Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-22-2012 11:43 PM
rdaex Ended up being a bit of a lip at the insertion point (heh heh) that I just dremeled off.
10-22-2012 11:19 AM
rambleon84 copy one of the pictures in the above post or take a picture of what you are asking, not sure. the above how-to illustrates most of it pretty well.

I didnt use a how-to and was able to figure out the install pretty easily. If i follow what you are asking, there was like a washer/locking thing i had to slightly unbend to install the cable and then rebend it back once installed.
10-21-2012 12:28 PM
rdaex AHHHH HELP

When I go to thread the cable into the new assembly... it wont go in.
The inside of each assembly has 3 right angles, and one like... notch, maybe a 45 degree angle. The cable seems to be made for that, but damned if I can get it to go on.

Is it as simple as PUSH REALLY FARKIN HARD, or am I missing something?
03-25-2012 02:31 PM
whimsicalpouch2 this is very helpful, since my leather was torn and i ended up tearing it off awhile back, now that my ebrake cable to my right rear tire is broken, might aswell fix it all at once, aswell as my other brake stuff i'm doing, my car will be all braked out haha
03-26-2008 12:04 PM
S2 Added to the 'How To Archive'....
03-25-2008 11:05 AM
CaysE I'm saying he should be able to attach the pics to his post rather than link them.
03-25-2008 10:45 AM
scrammer ^^lol
with the amount of How-To's that have been posted lately, im not suggesting that. i have submitted 5 to chad this month alone.
03-25-2008 10:13 AM
CaysE Just attach the pics instead of linking.

I found it easier to pop the ebrake boot out of the center console first and removing the nut on the ebrake cable; this way the ebrake handle could point straight up, allowing you to more easily get the console around it when you pull it off.
03-24-2008 11:07 PM
scrammer ok, this How-To is much better detailed than our current one. consider it stickied.
Chad will prolly be replacing the current with this one.

great job

oh and btw, FF.com nor I condone drinking alcoholic beverages while modding your FoFo. it just isnt a good idea. besides....Corona

checkmyvitals...please, please do not allow the pics in this How-To to be broken. so if you ever move these pics, make sure you update the links here. if you arent able by then (if its been too long), let me know so i can.
03-24-2008 09:39 PM
loudfocus01 A important tip for anyone doing this is don't pull out the old cable....use it instead of the one that comes with the svt ebrake handle. I pulled out the old cable, and had to freakin hook it back up from under the car since the part it hooked up to was way deep down in the hole. I had to move part of the heat shield out of the way.....such a big PITA that was. I got it installed now finally, and it looks great.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:06 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat