Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > Clutch Pedal Spring

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Clutch Pedal Spring Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-22-2009 01:38 PM
focusowner2 Hey
Ive got a 2005 focus estate, and my spring went a couple of days back.
I got a new spring from ford for 4, and then put it in this afternoon.
My lower mounting point looked kinda different to the photos already posted, but im pretty certain that ive got it in the correct position.
I did take some photos to upload to this forum, but I can't see how - it looks like you have to host them elsewhere and link to them?

Anyway, here is my advice...
It's nearly impossible to see the lower mounting point from lying with your back on the floor and your head under the dash. However, moving the steering wheel as far out and up as it will go affords a nice view from under the steering column. I also held my camera phone up under the dashboard with its light on enabling me to "see round corners"...
When fitting the spring, do the lower mounting point first, holding the spring vertically above the mounting point, and hooking in by moving the bottom of the spring towards the front of the car. Once it's hooked in, flop the spring towards the back of the car, and it lands on the pivot of the clutch pedal. Then get a screwdriver, and pull the free end of the spring onto the hook on top of the clutch pedal.

Hope it helps someone...
12-22-2008 03:19 PM
Sypher Hi all Just had the same thing fail on mine . I couldnt find the lower mount point staight off but I HAVE pics of where it mounts to for those that are interesed .

you can see the master cylinder pipes in the top pic ( this is looking inbetween the pipes to the pedal mounting )





zoomed in pic ( you can still see the remains of my spring in the pic ) .

The lower mount is a slip of steel with a slot , sticking out 90 degres from the pedal mount plate towards the clutch master cylinder pipes .

Hope this helps you guys out ???
02-10-2008 08:47 PM
FocusVet
Quote:
Originally Posted by ATXSVT View Post
Found the problem, broken Clutch Safety Switch.
That would do it! Glad you found the problem . Could you are anyone look at you clutch return spring and let me know when it hooks at the lower point(behind the clutch master cylinder). Thanks a bund!
02-10-2008 06:11 PM
ATXSVT Found the problem, broken Clutch Safety Switch.
02-10-2008 05:11 PM
19TbirdSC91 Spring wouldn't cause that problem, BUT the connectors probably could...makes sense to me.

Sean
02-10-2008 03:37 PM
ATXSVT Might sound like a newb q's but will that cause the car not to start? I believe I'm in the same situation.


Last night I went to my mom's job to bring her some food. No problems with the car. 20 mins later when I'm ready to leave the car won't start. When I turn the key, no turn over, no sound no nada. The light dash is on and the radio comes on. So I had to leave it there for a few hours. When I come back and was about to pull the hood latch, I look down and see a spring and 2 wires (red/black connected to a plastic piece) hanging on my clutch pedal. Going over the thread and seeing the similarities I'm wondering if this is the problem.

-Alie
02-09-2008 08:10 PM
RhodySVT yeah had that happen to me too mine was from the neutral safety switch. Pita but a little
superglue fixed me up
02-09-2008 07:24 PM
FocusVet biddy bumpy
02-09-2008 01:36 PM
FocusVet Here ya go, http://www.focusfanatics.com/forum/s...ad.php?t=87050 hope this helps, but I'm still looking for the proper place to hook in the lower mounting point.
02-09-2008 01:14 PM
19TbirdSC91
Clutch Pedal Spring

If this is a repost, i apologize, i searched around and can't find the answer anywhere. A spring went flying off my clutch pedal one day when i pushed it in, i went and got a new one from ford, but i cant tell where it came from. Thanks for your help.

Sean McConaha

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:22 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.