Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > ABS Light on - No ABS though

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: ABS Light on - No ABS though Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-14-2007 12:35 PM
DURATECoftheDesert
Quote:
Originally Posted by Sinan View Post
I don't think SE comes with ABS. Be it ZX3, Zx5 or ZX4. ABS is only available on SES models I believe.

I think I read something about ABS light in car's manual. It says something about ABS light being there just for the hell of it. Doesn't matter if car has ABS or not.
I agree too, As many times have I read the brochure SE came with an option with ABS and SES are Standard.
10-14-2007 10:20 AM
whynotthinkwhynot Sounds like a computer pin boo boo.... it would take a lot to figure it out. As long as the car is still working fine- then I wouldn't worry about it. If it really bugs you, then you might be able to remove the lamp for that light. To my knowledge Ford still uses lamps instead of LED's for dash lighting.
10-14-2007 10:18 AM
SAYTIN is it under warranty? i had this happen to my 04 zx5 5 speed manual, except it was the overdrive light.... same thign you guys are describing.... ford said there were a group of bad clusters, and i'd need mine replaced.... since it was replaced no problems....
10-13-2007 10:46 PM
dgrimshi
ABS light lit with no ABS brakes

I have a 06 Focus ZXW with a faintly lit ABS light. I definitely don't have ABS brakes. It's not always on but when it decides to light it stays on even with the ignition off. I have no tach in my instrument cluster. Has anyone found a solution for this?

Dave G.
01-19-2007 12:53 PM
SVT_BMXer
Quote:
Originally Posted by viney266 View Post
The light stays on AFTER you shut the car off? That doesn't sound right at all... A short , maybe?
Thats my guess. If the light stays on after you shut the car off something is def off there.
01-18-2007 07:35 PM
mikkopel Yep, it did stay on at least for a while even after I turned the car off. Now it's gone though. I'm suspecting that since it hasn't been quite as cold I haven't seen it come back.

Short is what I thought too, especially since it didn't seem to be fully lit. Doesn't sound too dangerous, but then again something that probably I should look into, before winding up with a dead battery...
01-18-2007 02:11 AM
viney266 The light stays on AFTER you shut the car off? That doesn't sound right at all... A short , maybe?
01-18-2007 01:24 AM
Sinan I don't think SE comes with ABS. Be it ZX3, Zx5 or ZX4. ABS is only available on SES models I believe.

I think I read something about ABS light in car's manual. It says something about ABS light being there just for the hell of it. Doesn't matter if car has ABS or not.
01-17-2007 10:50 AM
OTreborO I am no expert, but I am going to say that your 05 has ABS. All lights should go out after turning off the ignition.
01-17-2007 09:14 AM
mikkopel
ABS Light on - No ABS though

I have a '05 Focus ZX4 SE, and this morning when it was really cold,
I noticed that the ABS light was faintly lit in the dashboard.

But I don't think the car has ABS to begin with. And after driving to work,
I noticed that the light didn't go out even after shutting the car, and
taking the key out. I didn't notice any other problems with the car.

The ABS light doesn't have any function in the non-ABS model, does it? Or is it a warning of something else?

Maybe once it warms up, the light will go away...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:17 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.