Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > Need help with Fuel Pump

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Need help with Fuel Pump Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-08-2008 01:15 PM
dhardison
Quote:
Originally Posted by Mr.Bergner View Post
So I replaced the fuel pump with the one from CFM and my car hasn't ran better since I've bought it. AWESOME!!!!!!! I'm just glad that's all it is.

Thanks for your help! +1 for sure.
Dan,

You have a PM on this subject.

Thanks,
Dan
10-20-2007 08:11 PM
Mr.Bergner So I replaced the fuel pump with the one from CFM and my car hasn't ran better since I've bought it. AWESOME!!!!!!! I'm just glad that's all it is.

Thanks for your help! +1 for sure.
10-13-2007 06:28 PM
whynotthinkwhynot Flow shouldn't matter with this SFI design, the computer regulates the fuel pressure by reducing voltage to the pump. A higher flowing pump would just run at a lower voltage.

The worst thing I can think of that could be wrong would be the fuel pressure/temp sender. The only way to test it is to cut your fuel line and put a manual fuel pressure tester in line- or throw the part at the car and see if it fixes it. It's not a cheap part to throw at the car either- so that would be a last resort!
10-13-2007 06:18 PM
Mr.Bergner ^^Thanks
I'm definitely checking all that tomorrow.

In case I have to replace the fuel pump again, I just looked them up on CFM and noticed they have an 03-04 fuel pump that states the following:
"This pump is used on the 2003 to 2004 Ford Focus Models. This pump will out flow the stock 2000 to 2002 Ford Focus pumps. The flow numbers for this pump is shown below.

217lph @ 40psi
185lph @ 60 psi
143lph @ 80psi"

I'm not sure what they mean by "out flow", does that mean it will flow too hard or too much? I'm just thinking worst case here.
10-13-2007 06:12 PM
whynotthinkwhynot Your whole problem might've been spark plug wires to begin with, but that's all water under the bridge now.

If you purchase Lifetime Warranty plug wires at parts stores, then the next time you purchase the wires, you put the old ones back in the box and get your money back. Don't skimp on the price if you can get Lifetime warranty wires.

First off, pull the spark plugs. Google "Spark Plug Deposits" and look for a site with pictures. Then compare your plugs to the pictures to see if you can figure out what's going on inside the engine. That's the first step in diagnosing engine problems. Before you put the plugs back in- use a gap gauge- about $1- to check and see if the gap is correct.
10-13-2007 05:51 PM
Mr.Bergner
Need help with Fuel Pump

Okay, so we replaced my fuel pump and fuel filter on Wednesday. The fuel filter is a Motorcraft and I must admit, the pump was one of those damn cheapies from Advanced Auto Zone for like 63 bucks. The strainer that came with it would not fit into the pump housing so we cleaned off the original and used that instead. It started running like crap after five minutes of idle and then eventually died. We pulled everything apart again and inspected.

It runs now but still like crap. The only way I can accelerate is to baby the throttle. If I stomp on it while in drive, it's starts to bog, buck and surge. However, if it's in park or neutral it'll let me red line the rpms without issue.

I've had the EGR blocked off for about a year now due to a bad DPFE. I plan on getting an EGR delete. Don't know if that has anything to do with it. Tomorrow I'm going to check the spark plugs and replace the wires with my stock (i'm broke right now).

The reason for replacing the fuel pump is I had the usual symptoms of a failing fuel pump but my car is not under the recall (had Mike look it up for me). It started running like absolute crap this past week so that's what prompted me to replace it. I may pony up the bucks and get the actual pump from Mike.

Is there anything else someone can give me pointers to check or troubleshoot?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:51 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.