Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Performance (2002-2004) > Does your SVT ever just die?

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Does your SVT ever just die? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-23-2014 10:34 PM
Svteurobw My 04 svt had the same prob I did wires plugs fuel filter and never had it happen again in the last 30000 miles I used all ford parts incl the factory non copper plugs. now if u have a CAI I would try cleaning your mass air sensor I had a Nissan with one and every time it started stalling it was due to the sensor being dirty
03-23-2014 05:18 PM
s86chappy Iacv

so what is the number one thing to try.. So many people have done differnt things that worked for them..

Is iacv clean or replacment the best thing to do..?

Tune

02 sensors

spark plugs

fuel filter and fuel pump

tps
10-01-2013 09:43 PM
tdriver Cleaning my throttle body helps my car a lot.
09-30-2013 12:55 AM
blackonblacksvt03 Mine did this for two years until I put the cfm intake couplers in but I cleaned the TB at the same time I did that has not done it in 6 months or so it was a monthly happening and I never really worried about it
09-24-2013 09:48 PM
Evanc291 Gotcha, that makes sense
09-24-2013 09:47 PM
itr909 I was also told that the temperature can play a factor in a tune also
09-24-2013 09:45 PM
Evanc291 Hmm, that's why I was thinking, maybe it was tuned for a higher elevation.. Well thanking for confirming that could be the problem
09-24-2013 09:42 PM
itr909 I had a similar issue with my tune however my issue was due to elevation.
09-21-2013 03:10 PM
Evanc291 I have the same problem, I can pretty much count on it stalling if I let the rpm's drop, sometimes it's not a problem, but other times, it idles super rough. I bought the car and the previous owner definitely has has it tuned, it runs super rich at idle and also it has no cat. So unless there is a fake 02 sensor, he has tuned it.

I've done everything that could obviously be the problem. Cleaned the IAC, TB, no vacuum leaks, cleaned MAF sensor, fuel filter, air filter, and no battery or alternator problems. I did recently have a CEL for PO1131 and PO0133.. It's interesting though, every time I reset the ECU, it runs perfect, until I turn the car off. Also, sometimes it does that surge thing everyone is talking about. It feels like it's just dumping gas, and it also backfires a lot, and my miles per gallon is terrible right now. So do you think it just needs a new tune? Or maybe some fuel pressure problem.. I can't think of much else
09-19-2013 11:10 AM
qweesy You need a new set of battery cables.

Along with the Updated Alternator pigtail and Updated Ignition pigtail.

Electrical problems are a bitch but these 3 items solve the majority of them, the only other common problem I can think of electrically is the hatchback models rear harness in the hatch can become brittle and break causing electrical gremlins, and specifically to the SVT the headlamp switchmake sure the dimmer rheostat is just below the max setting to stop the flicker of the el-glo.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:33 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.