Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat > Desperation....

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Desperation.... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-21-2013 08:59 PM
iminhell Depending on how long the plug wells were full of water, something may have become corroded (plugs, wires). Not uncommon at all.

Other than that, have it scanned for pending codes and get back to us.
04-21-2013 07:52 PM
RabbleRouser
Desperation....

I'm new here, hoping to get some advice...I have a 2004 Focus SE with 117k on it, it's a 2.0 Zetec 4cyl. I bought it from a local dealer and I thought I was getting a decent deal...I've driven it for 60 miles...basically from the lot to my house, in that time it's ate 1/3 a tank of gas, hesitates to go into reverse if it's been running awhile, stutters uncontrollably, and ultimately shuts down if it's been running for more than 10 minutes...I'm thinking it's the Catalytic Converter that's burning everything up...as a side yesterday I found water down in the Plug housing and in and around the plug wires, we dried it out and it ran for awhile, but still sputtered.

Earlier I drove it down to my garage and it barely made it up the hill, as soon as I put it in reverse it started acting like it was low on gas and just sputtered but would move if I gave it just a littttle bit of gas, anything more and it just died out. We're taking it back to the lot tomorrow to hope they'll fix it, but I'm pretty much prepared to replace and pay for it all, I just need to know what I'll have to replace. Or at least general ideas of where to look.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:04 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat