Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus > Dome lights

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Dome lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-17-2014 02:56 PM
FordService
Quote:
Originally Posted by InfantryBlueRD View Post
I have a 2014 titanium, just bought it with 18,000 miles so still under warranty. But my done lights have never worked. I tried everything in this thread and no luck. When I tried to go to the link for cars built after 2012 it said access denied. I was on my phone so I could try it while in my car so I'll try it again from my laptop. But on here and in the owners manual it says Dome lights are turned off when the button is lite up Amber and the dome lights are activated when it's lite up blue, but mine won't light up blue. It's either Amber for off or no light at all. I haven't tried the methods using the different unlocking mothods but since my dome light only works when manually activated I don't think it will help. I don't know when I'll have time to take it to the dealer unless they will fix it while I wait because I'm in the military and have a packed schedule with no other means of transportation. But short of taking it to the dealer or getting that link to work for me does anyone have any advice
Here are the full instructions for the lights that you're referring to:

Quote:
INTERIOR LAMPS
The lamps will switch on when one of the following conditions have been met:
• You open any door.
• You press a remote control button.
• You press switch D on the front interior lamp.

Note: Press switch C on the front interior lamp to switch the courtesy and door illumination function off when you open any door. The indicator lamp will illuminate yellow when the door function is off. When the door function is off and you open a door, the courtesy and door lamps will stay off.

Press switch C again to switch them back on. The indicator lamp will illuminate blue when the door function is on. When the door function is on and you open a door, the courtesy and door lamps will switch on.
There's a diagram on page 95 that shows where the switches are.

Just to make sure I understand, have you tried pressing switch C to toggle it on and off? If so, and it's still not working, I recommend heading to your dealer for a diagnosis. I can also look into some additional assistance with the following info sent via private message: VIN, mileage, best daytime phone number, full name, and dealer name/location.

Thank you for your service,

Meagan
12-14-2014 08:59 PM
InfantryBlueRD Aside from this 1 issue I love this car and have no complaints regarding it. Before my 2014 titanium hatch I had a 2012 SEL hatch that was fully loaded minus seat warmers, camera and maybe 1 other thing and I had no issues with anything. No lighting issues or anything but someone blew a red light and tboned me totaling it last month. But I got this titanium with every option available except for Sun/Moonroof, I miss my sunroof so I may get one installed in the future, but I want to tint the windows and smoke the tail lights
12-14-2014 08:53 PM
InfantryBlueRD I have a 2014 titanium, just bought it with 18,000 miles so still under warranty. But my done lights have never worked. I tried everything in this thread and no luck. When I tried to go to the link for cars built after 2012 it said access denied. I was on my phone so I could try it while in my car so I'll try it again from my laptop. But on here and in the owners manual it says Dome lights are turned off when the button is lite up Amber and the dome lights are activated when it's lite up blue, but mine won't light up blue. It's either Amber for off or no light at all. I haven't tried the methods using the different unlocking mothods but since my dome light only works when manually activated I don't think it will help. I don't know when I'll have time to take it to the dealer unless they will fix it while I wait because I'm in the military and have a packed schedule with no other means of transportation. But short of taking it to the dealer or getting that link to work for me does anyone have any advice
11-12-2014 04:49 AM
Slicknick Unlocking the doors/two-stage unlock
1. Press and release to unlock the driverís door.
Note: The interior lamps and turn signal lamps will illuminate.
2. Press and release again within three seconds to unlock all the
doors. The turn signals will flash.
The remote entry system activates the illuminated entry feature; this
feature turns on the lamps for 25 seconds or until the ignition is turned
on.

Right from the book. If you are not getting it to illuminate on the first click, then it is not right.
09-24-2014 11:56 PM
mosene80 Hy,
My Focus is a 2013 SE salon, I also had a problem with the dome lights, a couple days ago my F60 fuse blow and I had no more interior lights, footwell lights and trunk light.
After I replace the burnout fuse, I got back the trunk light but the footwell lights wont come on, and the dome light will not turn on when you unlock the doors or open any door. It will only turn on when you pres the on/off button.
I have no idea what to do or where to look, can some one please help me.
Sorry for any misspelling, english is not my first language

Thanks
08-18-2014 11:25 AM
blekenbleu
2014 SE Sedan, grp 200A + moonroof: dome lights stuck on

IMO, any designer of a light switch embossed with "OFF" that does not actually turn lights off should be fired.


Dome lights were still on, after having been parked for over an hour in broad daylight,
with trunk and all doors closed and locked.

While sitting in the drivers seat, no combination of button presses,
(with or without starting the car) would extinguish dome lights.

Slogging thru this thread revealed the OFF switch's "purpose";
after activating OFF, then opening and closing the door several times
with random key lock and unlock button press combinations and sequences, dome lights eventually extinguished.

This appears to be a firmware bug; perhaps more than SYNC was outsourced to Microsoft?

Meanwhile, front passengers get a switch on their dome light; rear passengers do not..?!
11-04-2013 12:38 PM
WickerFF Took it in this morning and showed them the tsb for this and it was very appreciated, no more problem now. Works like it suppose to.
11-01-2013 06:58 AM
WickerFF Ok, thanks, I'll try that, might be easier than me trying to explain. lol I just tend to get a little excited about these things.
10-31-2013 11:44 PM
MHartfield
Quote:
Originally Posted by WickerFF View Post
Just wish I told them this instead, I'll just mention this when I take it in and maybe mention the tsb I found here too. Other than that, it's been a great car, even though I only had it a week. lol
Wicker:

I printed out 2 copies of the TSBs and gave one to my dealer when I was getting my oil changed. He was real appreciative of getting a copy of the TSB. The dealer performed the TSB and the lights have worked fine since.
10-31-2013 09:48 PM
WickerFF Well, I'm glad to see I'm not the only one with this minor problem. lol

I got a little anxious and called the dealer in and told them that the dome light doesn't come on when I unlock it and sometimes it does and got in for Monday morning.

Well, now that I found this thread and some more experimenting, I found it's doing this, lock it, leave it sit for a while then go out and unlock it, everything comes on except the dome light. Then if I unlock it then re lock it then unlock quickly, it works fine.

Just wish I told them this instead, I'll just mention this when I take it in and maybe mention the tsb I found here too. Other than that, it's been a great car, even though I only had it a week. lol
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:22 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat