Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Discussions > Ford Focus Builds & General Showroom > The TICK build thread

Ford Focus Builds & General Showroom Post pictures and information of your Focus being built or your car images here. We want to see your Focus! More Images: Visit Our Online Ford Focus Gallery

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: The TICK build thread Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-12-2016 10:28 PM
Magus2727 Got things wired up today. I tied into the Green/Blue wire that is the 25 Amp fuse for the front windows. Its a switched power and accessible from inside the car.

Routed wires and installed the gauge in my open location in my custom pod.

It's alive!!!!



Got it wired up and working. So far the 1 min drive I took it seems to read good and at WOT it does not look like I am running lean which is good news . But does look like I am running way richer than I need to. Going to watch how it behaves as I drive into work tomorrow once I go closed loop and am warmed up...

I did put a bottle of fuel treatment in the tank so not sure how that will impact the A/F but cant think it would have to much of an impact on A/F.

Now to get a laptop so I can plug in the Xcal and the Analog input to data log with Tom.
01-12-2016 09:20 AM
SvviftSVT hmmm.. i used to know. but its been so long that i don't remember. sorry bud
01-12-2016 07:44 AM
Magus2727 Thanks. Is there a good wire to tap into for switched 12v and lighting dimmer?
01-12-2016 05:58 AM
SvviftSVT Looking good magus.
01-12-2016 01:46 AM
prerunnerwannabe Makes good sense. Thanks man!
01-12-2016 12:25 AM
Magus2727 Not sure that would be a better question for Tom or your tuner. I think once you go with a SVT full length header or equivalent then the fear or going lean at high RPM'S is there. And with me doing track days where my car is around 5kRPM or higher for sustained lengths of time under WOT 90% of a 20+ min track session it was needed.

Got the CAT back installed, and found the place to snake the O2 gauge wire in through the fire wall. OEM'S should have a square plate that you can buy answer swap out that gives you egress holes. Would come standard as a blank panel but you could then buy one that has a few holes so you can route stuff through....

Going to wire up the gauge and tie down the cables tomorrow after work. Then fire it up and see how nit works.
01-11-2016 11:25 PM
prerunnerwannabe Very nice!
Not to thread jack or anything, but at what point on an NA build is getting a wide band needed?
01-11-2016 09:24 PM
Magus2727 Got the bung welded in:



O2 sensors installed:





I think the sensors look like they are in good path of the flow:

01-08-2016 06:11 PM
Magus2727 Well I decided that the bung was still a bit to tall to shaved it down some...



This now provides I think a good depth of the O2 sensor into the exhaust stream:





While I was at it and waiting for my dremmel battery to charge I went a head and shaved off all the posts:



I also cut off the wings that are by the top flange, this will give me some more room by the speed sensor connector. these were also serving no purpose and now that its all flush may try to wrap the CAT if I ever have some extra $ for exhaust wrap.

Going to have it TIG welded in on Monday. Wonder if High Temp JB Weld or Exhaust patch would work :-) ?
01-08-2016 02:41 PM
Magus2727 Got my AEM Wideband O2 sensor & Gauge. Uses the BOSCH LSU 4.9 sensor...



So need to get the bung welded in. I know there has been issues with some of the bungs have to large of a stand off and LOOK!



AEM one that came with the gauge on the left. one on the right is the Autometer one that I got for free when I just asked them in an email if I could get one to mock up in prep of getting one (this was a few years back when I was doing my rebuild). I am going to install the shorter one.

Got the CAT off the car, was not actually to bad. I noticed that I have a dark mark at the junction between the flex and the rest of the exhaust so have a small exhaust leak down there... going to take that off while I have the car up and put some exhaust patch around there.



Location of where I am going to place the new bung:



Fit check with the sensor, as long as it goes in at an angle I have lots of clearance for both.



Need to grind off the tab, I no longer have a heat shield so don't need the posts any more. I have the heat reflective tape still on the oil pan but thinking of wrapping the CAT in the DEI titanium exhaust wrap.? thoughts? keep the CAT to hot?

Is there anything I can or should do to clean the cat? soak in soapy water? spray TB cleaner? or other type of cleaner? Also should I do anything with the O2 sensors? they have carbon deposits but still function. I am guessing its one of those if its not broke don't try to fix it.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:12 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1